Bug 125015 - xirc2ps_cs Fedora Core 2 unable to activate Xircom network card
xirc2ps_cs Fedora Core 2 unable to activate Xircom network card
Status: CLOSED DUPLICATE of bug 123457
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Depends On:
  Show dependency treegraph
Reported: 2004-06-02 03:30 EDT by Clive Long
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:03:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Clive Long 2004-06-02 03:30:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Unable to activate and use Xircom PCMCIA ethernet card

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot system
2. Device eth0 is detected, but fails at startup
3. Try to activate eth0 from redhat-network utility. This fails. 

Actual Results:  2. Start up messages: 
localhost ifup: interface "eth0" not found
localhost network: Bringing up interface eth0: failed

3. Network Activation message: Activation failed

Expected Results:  The device eth0 is detected and activates and
connects to the ethernet network

Card also known as Xircom CE3-10/100 Fast Ethernet

Additional info:
Comment 1 Harald Hoyer 2004-06-02 04:37:19 EDT
device eth0 is detected? how do you know?
what does:
# /sbin/ifconfig eth0
what is in /etc/modprobe.conf?
Comment 2 Clive Long 2004-06-03 05:16:38 EDT
1. device eth0 is detected? how do you know?

1. As I have written in "Actual Results" in my original bug report.
From "System Logs"
localhost ifup: interface "eth0" not found
localhost network: Bringing up interface eth0: failed

ALSO in same log
localhost ifup: xirc2ps_cs device eth0 does not seem to be present,
delaying initialisation

2. what does: # /sbin/ifconfig eth0 output?

2. eth0: error fetching interface information:Device not found

3. what is in /etc/modprobe.conf?

3. alias eth0 xirc2ps_cs
alias snd-card ..
install snd-cs ...
remove snd-cs46xx ..
robe -r ...
alias usb-controller uhci-hcd

ALSO 4. 
The NIC hardware works when Win XP is booted on the same machine
Comment 3 James Hill 2004-06-10 17:14:57 EDT
This happened to me after I carried out an update.  However I have several different pc 
cards to chose from, and it appears that it may be the pcmcia drivers that may be at fault.  
Not the drivers for the cards but the actual PCMCIA device itself.  All cards failed to be 
recognised after the update.  The PCMCIA chip in use on my laptop is Ricoh based if that 
Comment 4 Clive Long 2004-06-10 18:46:38 EDT

I "feel" this is something to do with the order that Fedora tries to 
activate PCMCIA AFTER Attempted network start.

This feeling is a bit difficult to justify because I don't understand 
the details in the logs but ..

1. cardctl seems to suggest there are no PCMCIA cards in the laptop

2. Occassionally I can manually re-detect the hardware to "add" the 
PCMCIA cards then rerun network activation manualy

3. I saw somewhere a posting that indicated a change to a config file 
that RE-Starts network AFTER PCMCIA.

Maybe something in this area?

I don't understand this well enough to perform a systematic analysis
Comment 5 ramiro 2004-06-21 14:02:39 EDT
After completing Fedora's Core 2 installation the system displays a 
message "detecting new hardware" and right after that says something 
like " Xircom XXX Ethernet detected  - will remove configuration". 
Even if you click on "keep configuration" It will not work.
I've noticed that the Plug and Play abilities of RH Linux 9 are 
missing in Fedora - I use to plug and unplug PCMCIA devices while RHL 
9 and it would detect them. This is not happening in Fedora C 2
Comment 6 Clive Long 2004-06-22 05:53:27 EDT
This was fixed for me by the work-around in Bug Report

**************   COPY FOLLOWS *****************

dditional Comment #5 From Penelope Fudd  on 2004-05-21 03:52 -------

And for the final coup-de-grace, getting the boot process to print no
errors (like orinoco_cs not found, delaying initialization):

Edit /etc/sysconfig/network-scripts/ifcfg-eth0 and set 'ONBOOT=no'.

Eth0 still comes up when pcmcia comes up, a little later.

The line I changed in /etc/rc.d/init.d/pcmcia is 95:
        #if ! grep -q pcmcia /proc/devices ; then
        if ! cardctl status 2>&1 > /dev/null ; then

*** This bug has been marked as a duplicate of 123457 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:03:55 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.