Bug 1250177 - Investigate betxn plugins to ensure they return the correct error code
Investigate betxn plugins to ensure they return the correct error code
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 12:29 EDT by Noriko Hosoi
Modified: 2015-11-19 06:43 EST (History)
4 users (show)

See Also:
Fixed In Version: 389-ds-base-1.3.4.0-9.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:43:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noriko Hosoi 2015-08-04 12:29:43 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/47810

Some betxn plugins did not return error codes(they always return success).  This was because before there were betxn plugins, their returns codes did not affect the if the operation was accepted or aborted.  Now those errors do matter, and we need to make sure all the plugins are behaving correctly.
Comment 1 Noriko Hosoi 2015-08-04 12:31:53 EDT
Bug Description:  When the memberOf plugin tries to add memberOf attribute to
                  an entry during a mod-replace on a group, even though the
                  update to the user entry fails, but plugin still allows
                  the member to be added to the group.
Comment 2 Jenny Galipeau 2015-08-04 13:02:11 EDT
Please add steps to reproduce.
Comment 3 mreynolds 2015-08-04 14:46:23 EDT
script to verify fix:

ds/dirsrvtests/suites/betxn/betxn_test.py

Fixed upstream.
Comment 5 Viktor Ashirov 2015-08-19 05:01:34 EDT
Build tested: 389-ds-base-1.3.4.0-12.el7.x86_64

============================================================================ test session starts =============================================================================
platform linux2 -- Python 2.7.5 -- py-1.4.30 -- pytest-2.7.2 -- /usr/bin/python
rootdir: /tmp/test/ds/dirsrvtests/suites/betxns, inifile: 
collected 5 items 

../tmp/test/ds/dirsrvtests/suites/betxns/betxn_test.py::test_betxn_init PASSED
../tmp/test/ds/dirsrvtests/suites/betxns/betxn_test.py::test_betxt_7bit PASSED
../tmp/test/ds/dirsrvtests/suites/betxns/betxn_test.py::test_betxn_attr_uniqueness PASSED
../tmp/test/ds/dirsrvtests/suites/betxns/betxn_test.py::test_betxn_memberof PASSED
../tmp/test/ds/dirsrvtests/suites/betxns/betxn_test.py::test_betxn_final PASSED

========================================================================= 5 passed in 30.52 seconds ==========================================================================

Marking as VERIFIED.
Comment 6 errata-xmlrpc 2015-11-19 06:43:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2351.html

Note You need to log in before you can comment on or make changes to this bug.