Bug 1250204 - Enable two fedora themes, allowing user selector as default
Enable two fedora themes, allowing user selector as default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sddm (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: F23Target-kde
  Show dependency treegraph
 
Reported: 2015-08-04 14:02 EDT by Helio Chissini de Castro
Modified: 2015-08-14 22:23 EDT (History)
7 users (show)

See Also:
Fixed In Version: sddm-0.11.0-1.fc23
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 22:23:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Helio Chissini de Castro 2015-08-04 14:02:31 EDT
As a first entry login manager current sddm theme in Fedora 22 is not a non tech user easy entry.

As pointed on recent phoronix article, one of the low points on Fedora Plasma desktop is the login manager. 

As a common user, is basically not intuitive enter a login name and password.
For a computer regular user, this is a no brain.

So the proposal is make default plasma sddm theme as default, changing artwork to fedora standard, but using the user selection.

At same time, a power user that needs deal with several users and systems on network logins, have the current user + login dialog to change, if the user selection is not suitable for their needs.

The rational side of this is, a power user or sysadmin knows how to change and even decide best strategies for the machine, but a new user, coming to Linux, will just don't know how to deal, considering that in all other operational systems or in GDM it has a entry user image point.
Comment 1 Kevin Kofler 2015-08-04 14:11:19 EDT
So in short, we'd have one Fedora theme with user list (reskinned upstream Plasma default) and one without (current theme reskinned/updated for F23)? That makes sense.
Comment 2 Rex Dieter 2015-08-06 13:43:51 EDT
Working on this today, while updating to sddm-0.11 (part of bug #1209689).

The userlist variant I am using intially is simply the sddm 'breeze' theme, with standard fedora wallpaper swapped in.  Creating a sddm-breeze subpkg from plasma-workspace to contain it.
Comment 3 Fedora Blocker Bugs Application 2015-08-06 15:41:26 EDT
Proposed as a Freeze Exception for 23-alpha by Fedora user rdieter using the blocker tracking app because:

 Polished F23 sddm theme artwork (the existing theme works, but has received a fair amount of criticism for lacking polish, this one is much nicer)
Comment 4 Rex Dieter 2015-08-06 15:45:22 EDT
Once this lands in updates-testing, to test this (assuming you have sddm installed and enabled already):

dnf --enablerepo=updates-testing install sddm sddm-breeze

and reboot, you should see the nice new userlist-enable breeze-inspired theme.
Comment 5 Fedora Update System 2015-08-06 21:55:54 EDT
sddm-0.11.0-1.fc23,plasma-workspace-5.3.2-10.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/sddm-0.11.0-1.fc23,plasma-workspace-5.3.2-10.fc23
Comment 6 Adam Williamson 2015-08-07 18:11:43 EDT
No point having this proposed as an Alpha FE now Alpha has been approved.
Comment 7 Fedora Update System 2015-08-08 12:19:58 EDT
Package sddm-0.11.0-1.fc23, plasma-workspace-5.3.2-10.fc23:
* should fix your issue,
* was pushed to the Fedora 23 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sddm-0.11.0-1.fc23 plasma-workspace-5.3.2-10.fc23'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13028/sddm-0.11.0-1.fc23,plasma-workspace-5.3.2-10.fc23
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2015-08-14 22:23:33 EDT
sddm-0.11.0-1.fc23, plasma-workspace-5.3.2-10.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.