Bug 1250210 - [ActionController::RoutingError] No route matches {:controller=>"vm_or_template", :action=>"launch_html5_console", :id=>1000000000151}
[ActionController::RoutingError] No route matches {:controller=>"vm_or_templa...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity medium
: GA
: 5.4.2
Assigned To: Brian McLaughlin
Ramesh A
: ZStream
Depends On: 1246538
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 14:10 EDT by Chris Pelland
Modified: 2015-09-09 09:10 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.4.2.0
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, users assigned to an EVM Group using tags as assigned filters got an action not implemented error when accessing the remote console. Removing the assigned filter tags allowed the users to access the console successfully. This error was caused by missing routing information for console access. This bug was fixed by adding the missing routing information. Users are able to access the remote console successfully in the new version of CloudForms Management Engine.
Story Points: ---
Clone Of: 1246538
Environment:
Last Closed: 2015-09-09 08:26:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 CFME Bot 2015-08-06 13:39:35 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=9f7759faf626e84b0d3ba7aeb1481ea02fcab1bc

commit 9f7759faf626e84b0d3ba7aeb1481ea02fcab1bc
Author:     Brian McLaughlin <bmclaugh@redhat.com>
AuthorDate: Tue Aug 4 09:39:45 2015 -0400
Commit:     Brian McLaughlin <bmclaugh@redhat.com>
CommitDate: Thu Aug 6 10:28:43 2015 -0400

    Add missing console route
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1250210

 vmdb/config/routes.rb                            | 1 +
 vmdb/spec/routing/vm_or_template_routing_spec.rb | 1 +
 2 files changed, 2 insertions(+)
Comment 2 CFME Bot 2015-08-06 13:39:38 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=85224949d01561e823d8116af16c8bbb734b070b

commit 85224949d01561e823d8116af16c8bbb734b070b
Merge: 67e3cbd 9f7759f
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Aug 6 13:33:59 2015 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Aug 6 13:33:59 2015 -0400

    Merge branch 'bz1250210' into '5.4.z'
    
    Add missing console route
    
    Clean merge, upstream PR is here: https://github.com/ManageIQ/manageiq/pull/3714
    
    @dclarizi please review.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1250210
    
    See merge request !213

 vmdb/config/routes.rb                            | 1 +
 vmdb/spec/routing/vm_or_template_routing_spec.rb | 1 +
 2 files changed, 2 insertions(+)
Comment 4 Ramesh A 2015-08-28 13:15:32 EDT
Good to go.  Verified and working fine in 5.4.2.0.20150820153254_83e434d
Comment 6 errata-xmlrpc 2015-09-09 08:26:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1744.html

Note You need to log in before you can comment on or make changes to this bug.