Bug 1250219 - openstack-neutron requires python-oslo-rootwrap
openstack-neutron requires python-oslo-rootwrap
Status: CLOSED DUPLICATE of bug 1246599
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: lpeer
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 14:35 EDT by Lars Kellogg-Stedman
Modified: 2016-04-26 12:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-04 16:47:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Kellogg-Stedman 2015-08-04 14:35:13 EDT
Description of problem:

The openstack-neutron package requires python-oslo-rootwrap, but this fact is not reflected in the package dependencies.  Installing openstack-neutron from OSP 7 and trying to run `neutron-ovs-cleanup` yields:

  Traceback (most recent call last):
  File "/usr/bin/neutron-ovs-cleanup", line 6, in <module>
  from neutron.cmd.ovs_cleanup import main
  File "/usr/lib/python2.7/site-packages/neutron/cmd/ovs_cleanup.py", line 20, in <module>
  from neutron.agent.common import ovs_lib
  File "/usr/lib/python2.7/site-packages/neutron/agent/common/ovs_lib.py", line 26, in <module>
  from neutron.agent.common import utils
  File "/usr/lib/python2.7/site-packages/neutron/agent/common/utils.py", line 22, in <module>
  from neutron.agent.linux import utils
  File "/usr/lib/python2.7/site-packages/neutron/agent/linux/utils.py", line 34, in <module>
  from oslo_rootwrap import client
  ImportError: No module named oslo_rootwrap
 
Version-Release number of selected component (if applicable):

openstack-neutron-2015.1.0-12.el7ost.noarch
Comment 4 Lars Kellogg-Stedman 2015-08-04 16:47:20 EDT

*** This bug has been marked as a duplicate of bug 1246599 ***

Note You need to log in before you can comment on or make changes to this bug.