Bug 1250236 - openstack-neutron requires openstack-selinux >= 0.6.37-1
openstack-neutron requires openstack-selinux >= 0.6.37-1
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 7.0 (Kilo)
Assigned To: lpeer
Ofer Blaut
Depends On:
Blocks: track-osp6-osp7
  Show dependency treegraph
Reported: 2015-08-04 15:24 EDT by Lars Kellogg-Stedman
Modified: 2016-04-26 20:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-09-28 12:00:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lars Kellogg-Stedman 2015-08-04 15:24:27 EDT
openstack-neutron requires at least openstack-selinux-0.6.37-1.el7ost.noarch, but this is not reflected in the package dependencies.  If you upgrade openstack-neutron from OSP 6, the ovs-cleanup unit will fail because of:

  # audit2allow -a
  #============= neutron_t ==============
  allow neutron_t lib_t:dir remove_name;
  allow neutron_t neutron_tmp_t:sock_file create;
Comment 3 Lars Kellogg-Stedman 2015-09-28 12:00:06 EDT
As a matter of policy we don't add dependencies on openstack-selinux.  The current upgrade documentation includes an explicit "yum upgrade openstack-selinux" to work around this issue.

Note You need to log in before you can comment on or make changes to this bug.