Bug 1250255 - dnf refuses to install i686 optimized packages on i586 arch
dnf refuses to install i686 optimized packages on i586 arch
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 16:29 EDT by Kimmo Vuorinen
Modified: 2015-08-11 09:50 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-11 09:50:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kimmo Vuorinen 2015-08-04 16:29:15 EDT
Description of problem:
dnf refuses to install i686 optimized packages on i586 arch

Version-Release number of selected component (if applicable):
dnf-1.0.1-2.fc22

How reproducible:
every time

Steps to Reproduce:
1. dnf install mdadm-3.3.2-1.fc22.i686.rpm

Actual results:
Error: package mdadm-3.3.2-1.fc22.i686 is not installable

Expected results:
Package installs successfully

Additional info:
dnf also refuses to use i686 arch packages from repositories

Linux localhost 4.1.3-200.fc22.i686 #1 SMP Wed Jul 22 20:25:27 UTC 2015 i586 i586 i386 GNU/Linux
Comment 1 Kimmo Vuorinen 2015-08-04 17:15:58 EDT
It seems that this is not a bug in dnf and it works as expected, I was in an impression that i686 packages were only optimized for i686 and would work with i586.

So this problem is probably related to some other component of the system that thinks that AMD Geode LX is an i586 arch because os otherwise operates well

rpm will install packages, but it is a bit painful to install manually downloading
Comment 2 Honza Silhan 2015-08-11 09:50:08 EDT
You can a new file a bug for correct component. Closing this - not bug in DNF as you said.

Note You need to log in before you can comment on or make changes to this bug.