Bug 1250270 - Boxes app is too large for 1024x768 resolution in rhel7's default classim mode
Boxes app is too large for 1024x768 resolution in rhel7's default classim mode
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-boxes (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Zeeshan Ali
Desktop QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 19:33 EDT by Vladimir Benes
Modified: 2015-11-19 03:55 EST (History)
3 users (show)

See Also:
Fixed In Version: gnome-boxes-3.14.3.1-7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 03:55:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (24.83 KB, image/png)
2015-08-04 19:34 EDT, Vladimir Benes
no flags Details

  None (edit)
Description Vladimir Benes 2015-08-04 19:33:10 EDT
Description of problem:
if in 1024x768 resolution in GNOME classic mode, it can easily happen that buttons in bottom (and top) area are hidden behind window panel or top panel.

This should be fixed in Boxes by lowering a resolution a bit.  

Version-Release number of selected component (if applicable):
gnome-boxes-3.14.3.1-6

How reproducible:
always

Steps to Reproduce:
1.set 1024/768 resolution and log into classic mode
2.go into Boxes and right click any machine
3.click preferences

Actual results:
button hidden behind window list on bottom panel

Expected results:
button should be visible

Additional info:
Comment 1 Vladimir Benes 2015-08-04 19:34:59 EDT
Created attachment 1059263 [details]
screenshot
Comment 2 Matthias Clasen 2015-08-18 13:58:38 EDT
Here's a fix:

iff -up gnome-boxes-3.14.3.1/data/ui/wizard.ui.height gnome-boxes-3.14.3.1/data/ui/wizard.ui
--- gnome-boxes-3.14.3.1/data/ui/wizard.ui.height	2015-08-18 13:55:29.658240120 -0400
+++ gnome-boxes-3.14.3.1/data/ui/wizard.ui	2015-08-18 13:55:49.513308312 -0400
@@ -40,6 +40,7 @@
                 <property name="wrap">True</property>
                 <!-- Work around clutter size allocation issue (bz#677260) -->
                 <property name="max-width-chars">40</property>
+                <property name="width-chars">20</property>
                 <property name="use-markup">True</property>
                 <property name="label" translatable="yes">Creating a Box will allow you to use another operating system directly from your existing login.
Comment 6 errata-xmlrpc 2015-11-19 03:55:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2253.html

Note You need to log in before you can comment on or make changes to this bug.