Bug 1250318 - rh-vagrant1-vagrant owns unexpected files
rh-vagrant1-vagrant owns unexpected files
Status: CLOSED NOTABUG
Product: softwarecollections.org
Classification: Community
Component: sclo-vagrant1 (Show other bugs)
1.0
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Pavel Valena
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 03:01 EDT by Lukas Zachar
Modified: 2016-01-06 12:10 EST (History)
2 users (show)

See Also:
Fixed In Version: sclo-vagrant1-vagrant-1.7.4-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-06 12:10:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zachar 2015-08-05 03:01:32 EDT
Description of problem:

Package creates, 
* on rhel-6:
/etc/rpm/macros.vagrant.rh-vagrant1
/vagrant

* on rhel-7:
/usr/lib/rpm/macros.d/macros.vagrant.rh-vagrant1

IMO the rpm macro should be part of rh-vagrant1-build, the /vagrant should not be there at all (it is created only on rhel-6).


Version-Release number of selected component (if applicable):
rh-vagrant1-vagrant-1.7.2-5.el6.noarch
rh-vagrant1-vagrant-1.7.2-5.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. rpm -qf /vagrant
2. rpm -qf /etc/rpm/macros.vagrant.rh-vagrant1
3. rpm -qf /usr/lib/rpm/macros.d/macros.vagrant.rh-vagrant1


Actual results:
rh-vagrant1-vagrant 

Expected results:
1. no such file
2/3. rh-vagrant1-build

Additional info:
Comment 1 Vít Ondruch 2015-08-06 08:30:01 EDT
2 and 3 are correct. We need to have the macros always available, since they are used by %post and %preun scriptlets.


The 1 is caused by not available bash-completion. The macro with bash completion scripts location is expanded to empty string and hence the file ends up in /. The macro now fallbacks to some better value, although it is out of /opt directory. Not sure if it is the best solution ....
Comment 7 Pavel Valena 2016-01-06 12:10:08 EST
Sorry the rh-vagrant1 SCL in RHEL-6 is no longer supported. Files are not available.

In RHEL-7, there is no issue (files ownership is correct).

2, file /etc/rpm/macros.sclo-vagrant1-config is now owned by sclo-vagrant1-build.
3, file /usr/lib/rpm/macros.d/macros.vagrant.sclo-vagrant1 is owned by sclo-vagrant1.

Note You need to log in before you can comment on or make changes to this bug.