Bug 1250322 - rhel 6.7 upgrade 1.2.3 async -- libvirt errors attaching to rbd.
rhel 6.7 upgrade 1.2.3 async -- libvirt errors attaching to rbd.
Status: CLOSED NOTABUG
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Distribution (Show other bugs)
1.2.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.2.4
Assigned To: ceph-eng-bugs
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 03:25 EDT by Warren
Modified: 2015-10-20 19:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-20 19:32:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libvirt starting vm on 6.7 (758 bytes, text/plain)
2015-08-05 03:25 EDT, Warren
no flags Details

  None (edit)
Description Warren 2015-08-05 03:25:11 EDT
Created attachment 1059343 [details]
libvirt starting vm on 6.7

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

100% of the time

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Warren 2015-08-05 03:42:20 EDT
This was against the puddle for errata 20787.

Steps to reproduce are essentially bringing up a ceph cluster and trying to start a virtual machine.  This worked fairly smoothly on 7.1 but I ran into lots of issues on 6.7

Things that I tried have been:

 https://niranjanmr.wordpress.com/2013/03/20/auth-libvirt-using-polkit-in-fedora-18/

50-org.example-libvirt-remote-access.pkla  (part)

 the edits suggested in comment 8 in: https://bugzilla.redhat.com/show_bug.cgi?id=1062660

Adding the following to  /etc/polkit-1/rules.d/50-libvirt-ubuntu.rules

polkit.addRule(function(action, subject) {
     if (action.id == "org.libvirt.unix.manage" &&
         subject.user == "ubuntu") {
         return polkit.Result.YES;
     }
     if (action.id == "org.libvirt.unix.manage" &&
         subject.user == "libvirt") {
         return polkit.Result.YES;
     }
 });

On 7.1, I was able to get the virt-manager to connect as ubuntu (normal user).  On
6.7, I could only get it to connect as root.  The error pasted in the previous comment is what happens after I try to bring up a shutdown system.

Maybe I am thrashing a bit, but I think that the difference between 6.7 and 7.1 is substantial enough to warrant a bug report
Comment 3 Ken Dreyer (Red Hat) 2015-08-05 13:26:09 EDT
I think the issue is that RHEL 6 doesn't support Javascript-style PolicyKit settings. Can you please try again with the older-style policykit settings?

Create /etc/polkit-1/localauthority/50-local.d/libvirt.pkla with the following contents:

[Allow ubuntu UID libvirt management permissions]
Identity=unix-user:ubuntu
Action=org.libvirt.unix.manage
ResultAny=yes
ResultInactive=yes
ResultActive=yes
Comment 4 Warren 2015-08-05 18:42:10 EDT
I still run into the same issue with the policykit settings in Comment 3.
Comment 5 Ken Dreyer (Red Hat) 2015-08-05 18:45:56 EDT
You might need to restart the libvirtd service?
Comment 6 Ken Dreyer (Red Hat) 2015-10-19 13:14:29 EDT
After setting the appropriate policy file, and restarting libvirtd, is this still an issue?
Comment 7 Warren 2015-10-20 19:32:32 EDT
I was using a java-script style policy kit for rhel 6.  Chalk this up as a user error.

Note You need to log in before you can comment on or make changes to this bug.