Bug 1250327 - [RFE] Make Red Hat product available through downloadable templates
[RFE] Make Red Hat product available through downloadable templates
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: distribution (Show other bugs)
3.5.1
Unspecified Unspecified
unspecified Severity low
: ovirt-4.2.0
: ---
Assigned To: Barak
Pavel Stehlik
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 03:38 EDT by Sergio Ocon
Modified: 2017-06-06 14:35 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-06 14:35:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio Ocon 2015-08-05 03:38:27 EDT
Description of problem:
I am trying to create a RHEL + OSE inside a RHEV environment. There is no easy way to do that, because there are templates for RHEL for OSP and VMware, but not for RHEV. 

Version-Release number of selected component (if applicable):


How reproducible:
Create a RHEL VM inside a RHEV. You need to create a template manually with the ISO, or create a VM with a HD based on the qcow2 image we provide (but without envelope)


Steps to Reproduce:
1.
2.
3.

Actual results:
You need to perform a painful process to create a template of Red Hat product

Expected results:
You go to access.redhat.com and download a template. Import it into RHEV and press the button to create a new machine. Cloud-init, and not cloud-init, should be supported.

Additional info:
Comment 1 Yaniv Kaul 2015-09-16 10:57:45 EDT
Yaniv - looks like a PM work is mostly needed here?
Comment 2 Yaniv Lavi (Dary) 2015-09-22 06:05:37 EDT
You can upload images to base template on using image uploader tool.
What is the missing part for you?
Comment 4 Sergio Ocon 2015-09-22 10:39:24 EDT
Yaniv,

I would expect to have ova images to be imported directly into RHEV, with and without cloud-init. Latest version.

The current format, qcow2, is no way a substitute, I need to create a VM out of it, then delete all the information to make it a template, clone it into a template.... in VMWare same process is just one step.

If the last version of cloud-init does not freeze the VM for a couple of minutes, that would be enough, if the download steps explain how to deinstall cloud-init daemon.
Comment 5 Sergio Ocon 2015-10-29 15:37:19 EDT
More information:

If I try to download RHEL 7 to install it in RHEV, I want to process to be as smooth as possible.

Options right now for RHEL 7 are:
PassSync Installer (32-bit) 2.92 MB
RHEL 7.1 Supplementary DVD 263 MB
PassSync Installer (64-bit) 3.24 MB
KVM Guest Image 406 MB
RHEL 7.1 Boot ISO 342 MB
RHEL 7.1 Binary DVD   3.62 GB

I am missing one option:
- RHEL 7 Guest Image (OVA) for RHEV

And the same for Atomic.

It would take more than 3 hours of work per customer, and taking into account that sys-init is not working anymore, it is a must-
Comment 6 Yaniv Lavi (Dary) 2015-11-22 09:32:56 EST
What is the gap to allow us to do this?
Comment 7 Sandro Bonazzola 2015-11-23 07:58:45 EST
(In reply to Yaniv Dary from comment #6)
> What is the gap to allow us to do this?

IMHO Platform should just provide a cloud ready OVA and make it installable / upgradable by rpm as Fabian did for the engine appliance.
I think this is a releng bug to be opened on RHEL.
Comment 8 Fabian Deutsch 2015-11-23 08:15:59 EST
We have the RHEL guest images (qcow2) image which already includes cloud-init.

If it is just about creating an OVA wrapper, then it should be a small gap from the build side.

So to me the biggest question is, if Engine needs anything else besides cloud-init to import an image as a template.
Comment 9 Sandro Bonazzola 2015-11-30 07:51:44 EST
Yaniv what's the question?

Fabian: if the image is available as OVA it can be uploaded into an export domain and then imported as template. Anything else needed?
Comment 10 Fabian Deutsch 2015-11-30 08:05:58 EST
(In reply to Sandro Bonazzola from comment #9)
> Fabian: if the image is available as OVA it can be uploaded into an export
> domain and then imported as template. Anything else needed?

It don't see any big development gaps. The main issue is to give it the propper QE coverage.

Note You need to log in before you can comment on or make changes to this bug.