Bug 1250337 - Generate 'reason' file from dmesg log file
Generate 'reason' file from dmesg log file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: abrt (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.3
Assigned To: abrt
Martin Kyral
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 03:55 EDT by Matej Habrnal
Modified: 2016-11-03 23:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: abrt-2.1.11-39.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 23:06:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch 1/1: vmcore: generate 'reason' file in all cases (1.31 KB, patch)
2016-05-04 03:25 EDT, Matej Habrnal
no flags Details | Diff

  None (edit)
Description Matej Habrnal 2015-08-05 03:55:22 EDT
If kdump generates the dmesg log file (vmcore-dmesg.log), the vmcore's
post-create event doesn't generate 'reason' file. It is caused by
inappropriate use of 'abrt-dump-oops' where the event uses that helper
to parse the log file to generate 'backtrace' file instead of using it
with the '-u' argument to update the dump directory and create all
necessary files.

Additional info:
Easy fix, this upstream commit fixes the issue:
https://github.com/abrt/abrt/commit/7800a01bd0d7fa6e53564fc4394f126f2042775f
Comment 2 Matej Habrnal 2016-05-02 10:55:23 EDT
Upstream commit fixes the issue:
https://bugzilla.redhat.com/show_bug.cgi?id=1166633

Related upstream testcase:
https://github.com/abrt/abrt/pull/1138/commits/42f7c0bcebd5984430cb6b0cff77683813d94dc3
Comment 4 Matej Habrnal 2016-05-04 03:25:55 EDT
Created attachment 1153721 [details]
Patch 1/1: vmcore: generate 'reason' file in all cases
Comment 7 errata-xmlrpc 2016-11-03 23:06:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2307.html

Note You need to log in before you can comment on or make changes to this bug.