Bug 1250382 - The usage of --pxe with --nonetworks is not prevented in virt-install
Summary: The usage of --pxe with --nonetworks is not prevented in virt-install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.2
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-05 09:24 UTC by fwu
Modified: 2015-11-19 05:31 UTC (History)
5 users (show)

Fixed In Version: virt-manager-1.2.1-5.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 05:31:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2206 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2015-11-19 08:17:29 UTC

Description fwu 2015-08-05 09:24:05 UTC
Description of problem:
The usage of --pxe with --nonetworks is not prevented in virt-install

Version-Release number of selected component (if applicable):
virt-install-1.2.1-4.el7.noarch
libvirt-1.2.17-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. #virt-install -n vm1 -r 1024 --nonetworks --nodisks --pxe

Actual results:
WARNING  The guest's network configuration does not support PXE

Starting install...
Creating domain...                                       |    0 B     00:00 

The guest can be installed.

Expected results:
An error message should occur:
'ERROR  Can't use --pxe with --nonetworks

Additional info:
The bug cannot be reproduced in virt-install-1.1.0-12.el7.noarch.

Comment 4 Pavel Hrdina 2015-08-06 13:03:30 UTC
Upstream commit:

commit aebebbf879ff33af38f858aebc01a5de1cafb1a7
Author: Pavel Hrdina <phrdina>
Date:   Thu Aug 6 14:43:00 2015 +0200

    virt-install: report an error for pxe install without network
    
    Fix a regression where we used to report an error message if user
    specified pxe installation without any network (--nonetworks or
    --network none).
    
    Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1250382
    
    Signed-off-by: Pavel Hrdina <phrdina>

Comment 7 XiaoQing 2015-08-12 07:44:33 UTC
I can reproduce the bug with the build:
virt-install-1.2.1-4.el7.noarch
libvirt-1.2.17-2.el7.x86_64

Try to verify this bug with package:
virt-install-1.2.1-5.el7.noarch
libvirt-1.2.17-4.el7.x86_64

steps:

1. #virt-install -n vm1 -r 1024 --nonetworks --nodisks --pxe

2 #virt-install -n vm1 -r 1024 --nodisks --pxe

Result:
After step 1:
A error message occurs:
ERROR Can't use --pxe without any network.
No installation windows pops up
After step 2:
No error message occurs.
Installation window pops up and installs VM.

According to above result,move this bug from ON_QA to VERIFIED.

Comment 11 errata-xmlrpc 2015-11-19 05:31:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2206.html


Note You need to log in before you can comment on or make changes to this bug.