Bug 1250410 - [Backup]: Password of the peer nodes prompted whenever a glusterfind session is deleted.
[Backup]: Password of the peer nodes prompted whenever a glusterfind session ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterfind (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Milind Changire
bugs@gluster.org
: ZStream
Depends On: 1234213
Blocks: 1223636 1243785
  Show dependency treegraph
 
Reported: 2015-08-05 06:37 EDT by Milind Changire
Modified: 2016-04-19 03:46 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1234213
Environment:
Last Closed: 2016-02-15 01:43:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-08-05 06:39:52 EDT
REVIEW: http://review.gluster.org/11832 (tools/glusterfind: password prompts for peer nodes on delete) posted (#1) for review on release-3.7 by Milind Changire (mchangir@redhat.com)
Comment 2 Anand Avati 2015-08-19 02:27:15 EDT
REVIEW: http://review.gluster.org/11832 (tools/glusterfind: password prompts for peer nodes on delete) posted (#2) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 3 Anand Avati 2015-08-27 02:23:59 EDT
REVIEW: http://review.gluster.org/11832 (tools/glusterfind: password prompts for peer nodes on delete) posted (#5) for review on release-3.7 by Venky Shankar (vshankar@redhat.com)
Comment 4 Vijay Bellur 2015-11-18 23:38:58 EST
COMMIT: http://review.gluster.org/11832 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit 2810954798cebb20e87dcea592a55e20067c6d41
Author: Milind Changire <mchangir@redhat.com>
Date:   Thu Jul 16 15:36:17 2015 +0530

    tools/glusterfind: password prompts for peer nodes on delete
    
    SSH keys getting deleted on local node caused password prompts for peer
    nodes on a delete operation.
    
    This race for session directory cleanup on local node is now addressed
    by avoiding the delete path for local node in node_cmd()
    The session directory tree is deleted anyway in mode_delete()
    
    Change-Id: I51c4baf4f9c1ed3caa319d4163bef343bd621429
    BUG: 1250410
    Reviewed-on: http://review.gluster.org/11693
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/11832
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
Comment 5 Kaushal 2016-04-19 03:46:47 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.