Bug 1250414 - media check fails on DVD/netinst - "configured resource limit was exceeded"
Summary: media check fails on DVD/netinst - "configured resource limit was exceeded"
Keywords:
Status: CLOSED DUPLICATE of bug 1241704
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
Depends On:
Blocks: F23FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2015-08-05 10:57 UTC by Kamil Páral
Modified: 2015-10-02 23:46 UTC (History)
9 users (show)

Fixed In Version: 043-60.git20150811.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-02 23:46:33 UTC
Type: Bug


Attachments (Terms of Use)
boot screenshot (32.42 KB, image/png)
2015-08-05 10:57 UTC, Kamil Páral
no flags Details
full system journal (127.28 KB, text/plain)
2015-08-05 10:57 UTC, Kamil Páral
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1241704 0 unspecified CLOSED systemd no longer able to run checkisomd5 in initramfs 2021-02-22 00:41:40 UTC

Internal Links: 1241704

Description Kamil Páral 2015-08-05 10:57:05 UTC
Created attachment 1059408 [details]
boot screenshot

Description of problem:
If you run any non-Live media (DVD, netinst) and try to perform a media check (the default boot action), the check fails and the boot continues. A screenshot is attached. The journal says:

Aug 05 10:47:10 localhost systemd[1]: [/etc/systemd/system/checkisomd5@.service:2] Failed to resolve unit specifiers on Media check on %f, ignoring: Invalid argument
Aug 05 10:47:10 localhost systemd[1]: Created slice system-checkisomd5.slice.
Aug 05 10:47:10 localhost systemd[1]: Starting system-checkisomd5.slice.
Aug 05 10:47:10 localhost systemd[1]: checkisomd5@-dev-sr0.service: Failed to run 'start' task: Invalid argument
Aug 05 10:47:10 localhost systemd[1]: Failed to start checkisomd5@-dev-sr0.service.
Aug 05 10:47:10 localhost systemd[1]: checkisomd5@-dev-sr0.service: Unit entered failed state.
Aug 05 10:47:10 localhost systemd[1]: checkisomd5@-dev-sr0.service: Failed with result 'resources'.
Aug 05 10:47:10 localhost systemd[1]: Starting checkisomd5@-dev-sr0.service...
Aug 05 10:47:10 localhost dracut-initqueue[588]: Job for checkisomd5@-dev-sr0.service failed because a configured resource limit was exceeded. See "systemctl status checkisomd5@-dev-sr0.service" and "journalctl -xe" for details.


Version-Release number of selected component (if applicable):
F23 Alpha RC1 DVD/netinst

How reproducible:
always

Steps to Reproduce:
1. boot "Test this media" option

Comment 1 Kamil Páral 2015-08-05 10:57:30 UTC
Created attachment 1059409 [details]
full system journal

Comment 2 Kamil Páral 2015-08-05 10:58:34 UTC
This has been tested with a burned DVD, but can be also trivially reproduced in a VM by booting the iso directly.

Proposing as a blocker:
"Validation of install media must work correctly for all release-blocking images. "
https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria#Media_consistency_verification

Comment 3 Zbigniew Jędrzejewski-Szmek 2015-08-05 14:35:14 UTC
This looks like 1239226, but that was supposed to be fixed already. What version of dracut is there on the image?

Comment 4 Kamil Páral 2015-08-06 07:29:28 UTC
I don't know how to find that out, there's no RPM database on DVD/netinst. Dennis Gilmore has access to build logs, we can ask him. I'd expect the currently stable dracut version to be used, which seems to be to dracut-043-40.git20150710.fc23.2.

Comment 5 Fedora Update System 2015-08-11 10:14:35 UTC
dracut-043-60.git20150811.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/dracut-043-60.git20150811.fc23

Comment 6 Fedora Update System 2015-08-12 20:11:22 UTC
Package dracut-043-60.git20150811.fc23:
* should fix your issue,
* was pushed to the Fedora 23 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-043-60.git20150811.fc23'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13298/dracut-043-60.git20150811.fc23
then log in and leave karma (feedback).

Comment 7 Adam Williamson 2015-08-20 17:22:49 UTC
Discussed at 2015-08-20 blocker review meeting: http://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-08-20/f23-blocker-review.2015-08-20-16.05.log.txt . Accepted as a blocker per criterion cited in description.

Comment 8 Fedora Update System 2015-09-01 03:37:09 UTC
dracut-043-60.git20150811.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Kamil Páral 2015-09-01 08:39:32 UTC
F23 Beta TC1 contains older dracut-043-40.git20150710.fc23.2.x86_64, so we can't verify this yet. We need to wait for Beta TC2.

Comment 10 Adam Williamson 2015-09-22 01:48:24 UTC
Doesn't seem to work in Beta for me, either. Similar error about a resource limit being exceeded.

Comment 11 Kamil Páral 2015-10-01 14:10:52 UTC
Yes, this bug is still present with F23 TC1 Server DVD.

Comment 12 Harald Hoyer 2015-10-02 10:51:24 UTC
This is anaconda-diskroot starting checkisomd5 with the wrong parameter. reassigning

Comment 13 Brian Lane 2015-10-02 23:46:33 UTC

*** This bug has been marked as a duplicate of bug 1241704 ***


Note You need to log in before you can comment on or make changes to this bug.