This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1250441 - Sharding - Excessive logging of messages of the kind 'Failed to get trusted.glusterfs.shard.file-size for bf292f5b-6dd6-45a8-b03c-aaf5bb973c50'
Sharding - Excessive logging of messages of the kind 'Failed to get trusted.g...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: sharding (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Krutika Dhananjay
bugs@gluster.org
: Reopened, Triaged
Depends On:
Blocks: 1250834
  Show dependency treegraph
 
Reported: 2015-08-05 07:15 EDT by Krutika Dhananjay
Modified: 2016-06-16 09:28 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1250834 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:28:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2015-08-05 07:15:07 EDT
Description of problem:
On enabling features.shard on a volume which already has few files, performing operations on the mount is causing excessive logging of messages of the following kind:

[2015-08-05 10:57:48.743352] E [shard.c:232:shard_modify_size_and_block_count] 2-dis-shard: Failed to get trusted.glusterfs.shard.file-size for 0b2bd401-c438-4d57-8ae5-8d26105d3396

Turns out this is coming from readdir callback of shard translator where the translator unconditionally looks for the xattr 'trusted.glusterfs.shard.file-size' in every entry's rsp dict and logs this error on not finding it. But files that are not sharded (i.e., the ones that were created before sharding was enabled on the volume) will not (and should not!) have this xattr associated with them. So these logs are misleading and must be suppressed in readdir(p).
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2015-08-05 11:26:31 EDT
REVIEW: http://review.gluster.org/11843 (features/shard: Fix excessive logging in readdir(p) callback) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Anand Avati 2015-08-05 22:37:10 EDT
COMMIT: http://review.gluster.org/11843 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 611b2545b012d1c5d0700af6bc1a182f7aa2343a
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Wed Aug 5 16:58:01 2015 +0530

    features/shard: Fix excessive logging in readdir(p) callback
    
    On enabling features.shard on a volume which already has few files,
    performing operations on the mount was causing excessive logging of
    messages of the following kind:
    
    [2015-08-05 10:57:48.743352] E [shard.c:232:shard_modify_size_and_block_count]
    2-dis-shard: Failed to get trusted.glusterfs.shard.file-size for
    0b2bd401-c438-4d57-8ae5-8d26105d3396
    
    Turns out this is coming from shard_readdir_cbk() where the shard
    translator unconditionally looks for the xattr
    'trusted.glusterfs.shard.file-size' in every entry's rsp dict and
    logs this error on not finding it. But files that are not sharded
    (i.e., the ones that were created before sharding was enabled on the volume)
    will not (and should not) have this xattr associated with them.
    So these logs are misleading and must be suppressed in readdir(p).
    
    Change-Id: I8d268b4f90a8bf744c7851f1984f5a1b6968fb6a
    BUG: 1250441
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/11843
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Nagaprasad Sathyanarayana 2015-10-25 11:20:26 EDT
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.
Comment 4 Niels de Vos 2016-06-16 09:28:57 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.