Bug 1250442 - qemu-doc.html bad markup in section 3.3 Invocation
qemu-doc.html bad markup in section 3.3 Invocation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Markus Armbruster
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 07:18 EDT by Markus Armbruster
Modified: 2016-05-10 16:59 EDT (History)
7 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.484.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:59:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus Armbruster 2015-08-05 07:18:03 EDT
Description of problem:
In qemu-options.hx, the option table's @end table isn't at the end.  The options preceding get rendered correctly as <dl>.  The options after it get rendered incorrectly.  In my Firefox, this looks like

‘-nodefconfig’

    Normally QEMU loads a configuration file from sysconfdir/qemu.conf and sysconfdir/target-ARCH.conf on startup. The -nodefconfig option will prevent QEMU from loading these configuration files at startup. 

-readconfig file

Read device configuration from file. This approach is useful when you want to spawn QEMU process with many command line options but you don’t want to exceed the command line character limit. 

Version-Release number of selected component (if applicable):
Observed in 6.7, but I believe it goes all the way back to 6.0.

How reproducible:
Always

Steps to Reproduce:
1. Examine /usr/share/doc/qemu-kvm-0.12.1.2/qemu-doc.html

Actual results:
-nodefconfig and -readconfig are rendered differently.

Expected results:
-readconfig is rendered like -nodefconfig.

Additional info:
Fixed upstream in commit 3dbf2c7.  We should've backported it along with commit 
ed24cfa, but we committed an independent rewrite instead (commit 3dd83c0), and missed the fix.
Comment 2 Jeff Nelson 2016-01-18 16:51:23 EST
Fix included in qemu-kvm-0.12.1.2-2.484.el6
Comment 4 Guo, Zhiyi 2016-01-20 01:09:08 EST
Reproduce the issue on qemu-kvm-0.12.1.2-2.483.el6.x86_64:
layout format of -nodefconfig and -readconfig:
<dt> &lsquo;<samp>-nodefconfig</samp>&rsquo;</dt>
</dl>
 -readconfig <var>file</var>

Verified on qemu-kvm version:qemu-img-0.12.1.2-2.484.el6.x86_64:
layout format of -nodefconfig and -readconfig:
<dt> &lsquo;<samp>-nodefconfig</samp>&rsquo;</dt>
<dt> &lsquo;<samp>-readconfig <var>file</var></samp>&rsquo;</dt>
Comment 7 errata-xmlrpc 2016-05-10 16:59:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0815.html

Note You need to log in before you can comment on or make changes to this bug.