Bug 125047 - CAN-2004-0488 mod_ssl ssl_util_uuencode_binary() stack overflow
CAN-2004-0488 mod_ssl ssl_util_uuencode_binary() stack overflow
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-02 08:12 EDT by Mark J. Cox (Product Security)
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.0.50-2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-20 05:20:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark J. Cox (Product Security) 2004-06-02 08:12:48 EDT
A stack-based buffer overflow in the ssl_util_uuencode_binary
function in ssl_util.c for Apache mod_ssl when mod_ssl is
configured to trust the issuing CA, and "FakeBasicAuth" is
being used, could allow remote attackers to execute arbitrary
code via a client certificate with a long subject DN.  Public
to full-disclosure on 17May.  Fixed Apache 2 CVS 25May

It is quite unlikely that users will have a vulnerable configuration
of Apache, therefore this is of low risk.

        CAN-2004-0488 Affects: FC1
        CAN-2004-0488 Affects: FC2
Comment 1 Robert Scheck 2004-06-15 02:06:38 EDT
Joe, can we please get the fix for mod_ssl: security fix for overflow 
in FakeBasicAuth (CVE CAN-2004-0488), for FC1 and 2 which is already 
available in 2.0.49-5? I also can find a package fixing this 
vulnerability in a public testing tree...
Comment 2 Joe Orton 2004-07-20 05:20:05 EDT
Fixed by http://fedoranews.org/updates/FEDORA-2004-204.shtml.

Note You need to log in before you can comment on or make changes to this bug.