Bug 125051 - xinetd loop in malloc_consolidate, trying to write to syslog
xinetd loop in malloc_consolidate, trying to write to syslog
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-02 09:09 EDT by Alexander Istomin
Modified: 2014-08-31 19:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-03 14:23:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is the actual loop which is being performed (2.90 KB, text/plain)
2004-06-02 09:11 EDT, Alexander Istomin
no flags Details

  None (edit)
Description Alexander Istomin 2004-06-02 09:09:46 EDT
Description of problem:

I have some repeateable problem with xinetd under RH9, it fails to
infinite loop and has to be restarted manually, here is the sample:

$ ps axfw
28663 ?        R    8394:10 xinetd -stayalive -pidfile /var/run/xinetd.pid
19683 ?        Z      0:00  \_ [popa3d <defunct>]
20709 ?        Z      0:00  \_ [popa3d <defunct>]
21154 ?        Z      0:00  \_ [popa3d <defunct>]
21216 ?        Z      0:00  \_ [popa3d <defunct>]

# gdb /usr/sbin/xinetd --pid 28663      
GNU gdb Red Hat Linux (5.3post-0.20021129.18rh)
[skip]
0x400f0f43 in malloc_consolidate () from /lib/libc.so.6
(gdb) bt
#0  0x400f0f43 in malloc_consolidate () from /lib/libc.so.6
#1  0x400f0615 in _int_malloc () from /lib/libc.so.6
#2  0x400ef8a0 in malloc () from /lib/libc.so.6
#3  0x400e74c4 in open_memstream () from /lib/libc.so.6
#4  0x40153cf4 in vsyslog () from /lib/libc.so.6
#5  0x40153c65 in syslog () from /lib/libc.so.6
#6  0x08062242 in syslog_write ()
#7  0x08061971 in xlog_write ()
#8  0x08052cb1 in svc_log_success ()
#9  0x0805991a in server_start ()
#10 0x080597bb in server_run ()
#11 0x0805ab0c in svc_request ()
#12 0x08053772 in main_loop ()
#13 0x0805356e in main ()
#14 0x4009862d in __libc_start_main () from /lib/libc.so.6


Version-Release number components:
glibc-2.3.2-27.9.7
xinetd-2.3.11-1.9.0

How reproducible:

The problem is that I can't provide exact steps to reproduce that, but
probably that's related to some memory shortage. I just notice such
situation quite often on loaded machines.

Any help on how to track that problem more precisely is welcome.
Comment 1 Alexander Istomin 2004-06-02 09:11:45 EDT
Created attachment 100793 [details]
Here is the actual loop which is being performed
Comment 2 Jay Fenlason 2004-06-03 14:23:55 EDT
Red Hat Linux 9 is out of support these days.  If you can reproduce
the problem with the more recent xinetd included in Fedora Core 2,
open a new bug on it.

Note You need to log in before you can comment on or make changes to this bug.