Bug 125052 - Installer crash makes it impossible to install FC2
Installer crash makes it impossible to install FC2
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2004-06-02 09:18 EDT by Zenon Panoussis
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-07 14:43:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Zenon Panoussis 2004-06-02 09:18:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040126

Description of problem:
First installation on a new machine, anaconda crashes shortly after
formatting with traceback (/usr/lib/anaconda/)

gui.py, line 1048, in handleRenderCallback 
rw/progress_gui.py, line 242 in renderCallback
gui.py, line 763, in nextClicked
dispatch.py, line 169, in gotoNext
dispatch.py, line 237, in moveStep
     rc=apply(func, self.bindArgs(args))
packages.py, line 673, in doPreInstall
     method.mergeFullHeaders("%s//%s/base/hdlist2" % (self.tree,
hrdlist.py, line 336, in mergeFullHeaders
IndexError: list is out of range

What does "FD" refer to? Installation medium in general or literal
floppy disk? The installation is run from CD and the machine has no

This happens in both graphical and text mode. I tried custom
installation with some extra packages and minimal installation, both

The machine is an ASUS A7V266-EX, Athlon 1300+, 512 MB RAM, no swap.
The installation CD passes its own test.

How reproducible:

Steps to Reproduce:
1. Start installing
2. Crash
3. Continue cursing the buggiest RH release ever
Comment 1 Jeremy Katz 2004-06-08 15:56:30 EDT
Can you attach the full dump you received?
Comment 2 Zenon Panoussis 2004-06-11 09:47:15 EDT
What I pasted above is all I have. 

BTW, installing by FTP worked. 
Comment 3 Jeremy Katz 2004-10-07 14:43:24 EDT
This should be better in fc3.

Note You need to log in before you can comment on or make changes to this bug.