Bug 125054 - Attempted assignment to const variable halts build
Summary: Attempted assignment to const variable halts build
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-02 14:08 UTC by Steve Snyder
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: anacron-2.3-31
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-03 21:35:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Snyder 2004-06-02 14:08:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040120

Description of problem:
Rebuild of package anacron-2.3-30.src.rpm halts due to the code
attempting to assign a value to a variable declared as const.  The
failure is at line #79 of file /usr/src/redhat/BUILD/anacron-2.3/gregor.c.


Version-Release number of selected component (if applicable):
2.3-30

How reproducible:
Always

Steps to Reproduce:
1.rpmbuild --rebuild anacron-2.3-30.src.rpm
2.
3.
    

Actual Results:  Build halts at compiler error.

Expected Results:  Build of this package should continue to completion.

Additional info:

Removing the "const" from the variable declaration fixes the problem.

Comment 1 Jason Vas Dias 2004-08-03 21:35:25 UTC
fixed in anacron-2.3-31.


Note You need to log in before you can comment on or make changes to this bug.