Bug 1250550 - Allow snapperd one-way communication with clients via pipe
Allow snapperd one-way communication with clients via pipe
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.2
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Lukas Vrabec
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 08:47 EDT by Ondrej Kozina
Modified: 2015-11-19 05:43 EST (History)
7 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-39.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 05:43:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Kozina 2015-08-05 08:47:29 EDT
Could you please allow snapperd to pass data (one way only) via pipe negotiated over dbus?

type=AVC msg=audit(1438778241.065:237): avc:  denied  { read } for  pid=1550 comm="dbus-daemon" path="pipe:[63866]" dev="pipefs" ino=63866 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:snapperd_t:s0-s0:c0.c1023 tclass=fifo_file

We do not open new hole since snapper is already effectively bypassing MAC by passing list of files over dbus already. Now we just send the list via pipe because of dbus message size limitations


Version-Release number of selected component (if applicable):
snapper-0.1.7-10.el7
selinux-policy-3.13.1-36.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. create two snapshot with snapper (so that diff is non-empty)
2. run snapper -c some_name status 1..2 (1 and 2 are snapshots created in step 1.)


Actual results:
[root@ibm-p8-02-lp3 xfs]# snapper -c xfs status 1..2
Failure (org.freedesktop.DBus.Error.NoReply).
Comment 2 Milos Malik 2015-08-05 09:04:06 EDT
Does the scenario trigger any other AVCs in permissive mode?
Comment 3 Ondrej Kozina 2015-08-06 04:14:22 EDT
This is full listing. AFAICT only the read denial is blocking snapperd from sending data back to clients.

type=AVC msg=audit(1438848621.979:313): avc:  denied  { noatsecure } for  pid=30847 comm="snapperd" scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:snapperd_t:s0-s0:c0.c1023 tclass=process

type=AVC msg=audit(1438848621.979:313): avc:  denied  { siginh } for  pid=30847 comm="snapperd" scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:snapperd_t:s0-s0:c0.c1023 tclass=process

type=AVC msg=audit(1438848621.979:313): avc:  denied  { rlimitinh } for  pid=30847 comm="snapperd" scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:snapperd_t:s0-s0:c0.c1023 tclass=process

type=AVC msg=audit(1438848622.149:314): avc:  denied  { read } for  pid=1393 comm="dbus-daemon" path="pipe:[58763]" dev="pipefs" ino=58763 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:snapperd_t:s0-s0:c0.c1023 tclass=fifo_file
Comment 6 Miroslav Grepl 2015-08-06 10:34:19 EDT
We want to allow

type=AVC msg=audit(1438848622.149:314): avc:  denied  { read } for  pid=1393 comm="dbus-daemon" path="pipe:[58763]" dev="pipefs" ino=58763 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:snapperd_t:s0-s0:c0.c1023 tclass=fifo_file
Comment 10 errata-xmlrpc 2015-11-19 05:43:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2300.html

Note You need to log in before you can comment on or make changes to this bug.