Bug 1250557 - audit2why and audit2allow exception on F23
audit2why and audit2allow exception on F23
Status: CLOSED DUPLICATE of bug 1249388
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 09:02 EDT by Stephen Gallagher
Modified: 2015-08-05 09:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-05 09:15:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2015-08-05 09:02:58 EDT
Description of problem:
Both 'audit2why -a' and 'audit2allow -a' fail with an exception on Fedora 23 Alpha RC1

Version-Release number of selected component (if applicable):
policycoreutils-python-utils-2.4-7.fc23.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. 'audit2why -a'

Actual results:
Traceback (most recent call last):
  File "/usr/bin/audit2allow", line 360, in <module>
    app.main()
  File "/usr/bin/audit2allow", line 346, in main
    self.__read_input()
  File "/usr/bin/audit2allow", line 164, in __read_input
    parser.parse_string(messages)
  File "/usr/lib64/python3.4/site-packages/sepolgen/audit.py", line 478, in parse_string
    lines = input.split('\n')
TypeError: 'str' does not support the buffer interface


Expected results:
A list of the AVCs

Additional info:
Comment 1 Stephen Gallagher 2015-08-05 09:15:03 EDT
This is probably a dupe of 1249388

*** This bug has been marked as a duplicate of bug 1249388 ***

Note You need to log in before you can comment on or make changes to this bug.