Bug 1250568 - FTBFS on big endians
FTBFS on big endians
Status: CLOSED DUPLICATE of bug 1276061
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
23
s390x Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2015-08-05 09:22 EDT by Dan Horák
Modified: 2015-11-06 11:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-06 11:21:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2015-08-05 09:22:28 EDT
build on s390 fails with

...
[build CUT] vcl_outdev
S=/builddir/build/BUILD/libreoffice-5.0.0.5 && I=$S/instdir && W=$S/workdir &&  mkdir -p $W/CppunitTest/ && rm -fr $W/CppunitTest/vcl_outdev.test.user && mkdir $W/CppunitTest/vcl_outdev.test.user &&    rm -fr $W/CppunitTest/vcl_outdev.test.core && mkdir $W/CppunitTest/vcl_outdev.test.core && cd $W/CppunitTest/vcl_outdev.test.core && (LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"$I/program:$I/program":$W/UnpackedTarball/cppunit/src/cppunit/.libs        $W/LinkTarget/Executable/cppunittester $W/LinkTarget/CppunitTest/libtest_vcl_outdev.so --headless "-env:BRAND_BASE_DIR=file://$S/instdir" "-env:BRAND_SHARE_SUBDIR=share" "-env:UserInstallation=file://$W/CppunitTest/vcl_outdev.test.user"   "-env:CONFIGURATION_LAYERS=xcsxcu:file://$I/share/registry xcsxcu:file://$W/unittest/registry"  "-env:UNO_TYPES=file://$I/program/types.rdb file://$I/program/types/offapi.rdb"  "-env:UNO_SERVICES=file://$W/Rdb/ure/services.rdb file://$W/ComponentTarget/configmgr/source/configmgr.component file://$W/ComponentTarget/i18npool/util/i18npool.component file://$W/ComponentTarget/ucb/source/core/ucb1.component"  -env:URE_INTERNAL_LIB_DIR=file://$I/program -env:LO_LIB_DIR=file://$I/program -env:LO_JAVA_DIR=file://$I/program/classes --protector $W/LinkTarget/Library/unoexceptionprotector.so unoexceptionprotector --protector $W/LinkTarget/Library/unobootstrapprotector.so unobootstrapprotector   --protector $W/LinkTarget/Library/libvclbootstrapprotector.so vclbootstrapprotector    > $W/CppunitTest/vcl_outdev.test.log 2>&1 || ( RET=$?; $S/solenv/bin/gdb-core-bt.sh $W/LinkTarget/Executable/cppunittester $W/CppunitTest/vcl_outdev.test.core $RET >> $W/CppunitTest/vcl_outdev.test.log 2>&1; cat $W/CppunitTest/vcl_outdev.test.log; $S/solenv/bin/unittest-failed.sh Cppunit vcl_outdev LINUX))
[build CUT] vcl_wmf_test
/builddir/build/BUILD/libreoffice-5.0.0.5/vcl/qa/cppunit/outdev.cxx:68:VclOutdevTest::testVirtualDevice
equality assertion failed
- Expected: 16777215
- Actual  : 16776960
outdev.cxx:68:Assertion
Test name: VclOutdevTest::testVirtualDevice
equality assertion failed
- Expected: 16777215
- Actual  : 16776960
Failures !!!
Run: 1   Failure total: 1   Failures: 1   Errors: 0
Error: a unit test failed, please do one of:
export DEBUGCPPUNIT=TRUE            # for exception catching
export CPPUNITTRACE="gdb --args"    # for interactive debugging on Linux
export VALGRIND=memcheck            # for memory checking
and retry using: make CppunitTest_vcl_outdev
/builddir/build/BUILD/libreoffice-5.0.0.5/solenv/gbuild/CppunitTest.mk:87: recipe for target '/builddir/build/BUILD/libreoffice-5.0.0.5/workdir/CppunitTest/vcl_outdev.test' failed
make[1]: *** [/builddir/build/BUILD/libreoffice-5.0.0.5/workdir/CppunitTest/vcl_outdev.test] Error 1

for full logs please see http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1928555

Currently this is from 32-bit s390, but I think I saw the same failure on other big endian arches in the LO 5.0 series.

Version-Release number of selected component (if applicable):
libreoffice-5.0.0.5-1.fc23
Comment 1 Ngo Than 2015-11-06 08:39:23 EST
it should be fixed in 5.0.3.2-4.

http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1978794
Comment 2 David Tardon 2015-11-06 11:21:17 EST

*** This bug has been marked as a duplicate of bug 1276061 ***

Note You need to log in before you can comment on or make changes to this bug.