Bug 1250601 - nfs-ganesha: remove the entry of the deleted node
nfs-ganesha: remove the entry of the deleted node
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: common-ha (Show other bugs)
3.7.3
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Reopened, Triaged
Depends On:
Blocks: 1216951 1240502
  Show dependency treegraph
 
Reported: 2015-08-05 10:21 EDT by Kaleb KEITHLEY
Modified: 2016-06-16 09:28 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1240502
Environment:
Last Closed: 2016-06-16 09:28:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-08-05 11:20:31 EDT
REVIEW: http://review.gluster.org/11841 (common-ha: delete virt-IP entry of deleted node) posted (#1) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Anand Avati 2015-08-19 00:46:46 EDT
REVIEW: http://review.gluster.org/11841 (common-ha: delete virt-IP entry of deleted node) posted (#2) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 3 Anand Avati 2015-08-19 09:55:27 EDT
REVIEW: http://review.gluster.org/11841 (common-ha: delete virt-IP entry of deleted node) posted (#3) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 4 Anand Avati 2015-08-21 07:55:40 EDT
COMMIT: http://review.gluster.org/11841 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit aee983ff43655771a9102592a284d0b0a29ad89f
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Aug 5 11:16:34 2015 -0400

    common-ha: delete virt-IP entry of deleted node
    
    Avoid accumulating invalid/defunct virtual IP entries in the HA
    config file.
    
    use correct 'clean' name when adding a node and its virtual IP
    
    Also fix a nit in the sample HA config file
    
    Change-Id: I2b7ca279f6390ee34b4e0689039eb7d846ed7e34
    BUG: 1250601
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/11841
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Meghana M <mmadhusu@redhat.com>
    Reviewed-by: soumya k <skoduri@redhat.com>
Comment 5 Kaushal 2015-09-09 05:39:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 6 Vijay Bellur 2016-03-14 07:45:12 EDT
REVIEW: http://review.gluster.org/13717 (common-ha: delete virt-IP entry of deleted node) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 7 Vijay Bellur 2016-03-15 00:22:25 EDT
COMMIT: http://review.gluster.org/13717 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 4bf4bab995307a87487abf3cb0808f81bf198ecd
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Aug 5 11:16:34 2015 -0400

    common-ha: delete virt-IP entry of deleted node
    
    Avoid accumulating invalid/defunct virtual IP entries in the HA
    config file.
    
    use correct 'clean' name when adding a node and its virtual IP
    
    Also fix a nit in the sample HA config file
    
    BUG: 1250601
    Change-Id: I0e6a251334e854d0003d5930ca804f972900b624
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/11841
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Meghana M <mmadhusu@redhat.com>
    Reviewed-by: soumya k <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/13717
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 8 Niels de Vos 2016-06-16 09:28:57 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.