Bug 125064 - elinks can't download files greater than 2GiB regardless of FS large file support
elinks can't download files greater than 2GiB regardless of FS large file sup...
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: elinks (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-02 10:37 EDT by Illtud Daniel
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-02 11:15:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Illtud Daniel 2004-06-02 10:37:30 EDT
Description of problem:
Links can't download files over 2GiB, although the filesystem will
support it.

Version-Release number of selected component (if applicable):
elinks-0.4.2-7

How reproducible:
always

Steps to Reproduce:
1. Find file greater than 2GB to download
2. Try it.
3.
  
Actual results:
Fails with "File size limit exceeded"

Expected results:
Not to fail.

Additional info:
RHAS can cope fine with files over 2GiB, but I'm guessing that LFS
(large file support) was not compiled into this elinks package.
This is as cribbed from various google searches, the best result of
which was this page: http://www.suse.de/~aj/linux_lfs.html
(don't knock it cos it's SuSe :> ). If that isn't the reason, I don't
know what is, but it's a damn pain as I'm downloading backup dumps of
29GB and getting nowhere (and can't use wget as the d/l is the reuslt
of a POST form submit, and I don't have X for graphical browsers).
Comment 1 Tim Waugh 2004-06-02 11:15:58 EDT
A fixed package has been built for Fedora development, and will appear
in a future release of Red Hat Enterprise Linux.  Thanks for the report.
Comment 2 Petr Baudis 2004-10-12 15:45:32 EDT
Wow. In that case, could you please share the patch for large files
support with us? :)

(We would be very grateful for you reporting bugs in the software
itself to the upstream anyway...)
Comment 3 Tim Waugh 2004-10-13 05:00:13 EDT
Just add '$(getconf LFS_CFLAGS)' to CFLAGS when you build. :-)

Note You need to log in before you can comment on or make changes to this bug.