Bug 125072 - At startup, pcmcia-cs symlinks /dev/modem to invalid device
Summary: At startup, pcmcia-cs symlinks /dev/modem to invalid device
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pcmcia-cs (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-02 15:31 UTC by Steve Snyder
Modified: 2015-01-04 22:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 20:35:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Snyder 2004-06-02 15:31:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040120

Description of problem:
At system start-up the pcmcia-cs package correctly detects that I have
a modem in a PCMCIA slot.  It then creates a "/dev/modem" symlink,
linked to the serial port /dev/cua6.  That's bad because this devnode
does not exist.  Thus /dev/modem is a dangling (and useless) symlink.

Manually removing the symlink and doing a "ln -s /dev/ttyS6
/dev/modem" fixes the situation and allows me to access the device via
/dev/modem.


Version-Release number of selected component (if applicable):
3.2.7-1.5

How reproducible:
Always

Steps to Reproduce:
1. Start pcmcia-cs daemon (as part of system startup)
2. The daemon correctly detects that a modem card is in the machine.
3.  
    

Actual Results:  Bad /dev/modem symlink created, linked to missing
/dev/cua6 devnode.

Expected Results:  Symlink /dev/modem should be linked to devnode
/dev/ttyS6.

Additional info:

The pcmcia-cs daemon is aware of the actual serial port:

# cat /var/lib/pcmcia/stab
Socket 0: Serial or Modem
0       serial  serial_cs       0       ttyS6   4       70

See file /etc/pcmcia/serial.opts for the setting of the LINK variable.

I'm reporting this as Normal (rather than Low) in severity for the
benefit of newbies who only know that the PCMCIA modem in their
notebook doesn't work.

Comment 1 Jani Ollikainen 2004-06-03 06:24:21 UTC
Normally doing the symlink will remove it and so on.
The proper fix is to edit /etc/pcmcia/serial at line 46/110:

The line is:
if match `uname -r` "2.[2345].*"; then

It should be
if match `uname -r` "2.[23456].*"; then



Comment 2 Steve Snyder 2005-03-21 16:16:56 UTC
Attention davej@redhat.com: this bug was fixed months ago.  In FC2, package
pcmcia-cs-3.2.7-1.8.2.2.src.rpm contains the corrected "serial" file.  FYI.


Comment 3 Dave Jones 2005-03-21 20:35:57 UTC
thanks Steve, will close.


Note You need to log in before you can comment on or make changes to this bug.