Bug 1250740 - [abrt] pnmixer: snd_mixer_detach(): pnmixer killed by SIGSEGV
[abrt] pnmixer: snd_mixer_detach(): pnmixer killed by SIGSEGV
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pnmixer (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:fd17283e6f0f9ae222eee9ddda8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 17:02 EDT by Giulio 'juliuxpigface'
Modified: 2016-07-27 19:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-03 17:32:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (12.02 KB, text/plain)
2015-08-05 17:02 EDT, Giulio 'juliuxpigface'
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-05 17:02 EDT, Giulio 'juliuxpigface'
no flags Details
File: core_backtrace (2.06 KB, text/plain)
2015-08-05 17:03 EDT, Giulio 'juliuxpigface'
no flags Details
File: dso_list (8.90 KB, text/plain)
2015-08-05 17:03 EDT, Giulio 'juliuxpigface'
no flags Details
File: environ (1.17 KB, text/plain)
2015-08-05 17:03 EDT, Giulio 'juliuxpigface'
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-05 17:03 EDT, Giulio 'juliuxpigface'
no flags Details
File: maps (39.97 KB, text/plain)
2015-08-05 17:03 EDT, Giulio 'juliuxpigface'
no flags Details
File: mountinfo (3.31 KB, text/plain)
2015-08-05 17:03 EDT, Giulio 'juliuxpigface'
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-05 17:03 EDT, Giulio 'juliuxpigface'
no flags Details
File: open_fds (352 bytes, text/plain)
2015-08-05 17:03 EDT, Giulio 'juliuxpigface'
no flags Details
File: proc_pid_status (996 bytes, text/plain)
2015-08-05 17:03 EDT, Giulio 'juliuxpigface'
no flags Details
File: var_log_messages (307 bytes, text/plain)
2015-08-05 17:03 EDT, Giulio 'juliuxpigface'
no flags Details

  None (edit)
Description Giulio 'juliuxpigface' 2015-08-05 17:02:52 EDT
Description of problem:
Description of the problem:
pnmixer crashes on Fedora-Live-LXDE-x86_64-23_Alpha-1.iso.

How reproducible:
Always.

Steps to reproduce:
1. Log in to a LXDE session.
2. Log out.
3. Log in to LXDE again.

Actual results:
pnmixer crashes.

Expected results:
pnmixer should not crash because of a normal login.

Version-Release number of selected component:
pnmixer-0.5.1-11.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        pnmixer
crash_function: snd_mixer_detach
executable:     /usr/bin/pnmixer
global_pid:     2027
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (6 frames)
 #0 snd_mixer_detach at mixer.c:256
 #1 close_mixer at alsa.c:195
 #2 get_channels at alsa.c:221
 #3 get_cards at alsa.c:53
 #4 alsaset at alsa.c:244
 #5 alsa_init at alsa.c:350

Potential duplicate: bug 893724
Comment 1 Giulio 'juliuxpigface' 2015-08-05 17:02:57 EDT
Created attachment 1059659 [details]
File: backtrace
Comment 2 Giulio 'juliuxpigface' 2015-08-05 17:02:59 EDT
Created attachment 1059660 [details]
File: cgroup
Comment 3 Giulio 'juliuxpigface' 2015-08-05 17:03:01 EDT
Created attachment 1059661 [details]
File: core_backtrace
Comment 4 Giulio 'juliuxpigface' 2015-08-05 17:03:03 EDT
Created attachment 1059662 [details]
File: dso_list
Comment 5 Giulio 'juliuxpigface' 2015-08-05 17:03:05 EDT
Created attachment 1059663 [details]
File: environ
Comment 6 Giulio 'juliuxpigface' 2015-08-05 17:03:06 EDT
Created attachment 1059664 [details]
File: limits
Comment 7 Giulio 'juliuxpigface' 2015-08-05 17:03:13 EDT
Created attachment 1059665 [details]
File: maps
Comment 8 Giulio 'juliuxpigface' 2015-08-05 17:03:14 EDT
Created attachment 1059666 [details]
File: mountinfo
Comment 9 Giulio 'juliuxpigface' 2015-08-05 17:03:16 EDT
Created attachment 1059667 [details]
File: namespaces
Comment 10 Giulio 'juliuxpigface' 2015-08-05 17:03:18 EDT
Created attachment 1059668 [details]
File: open_fds
Comment 11 Giulio 'juliuxpigface' 2015-08-05 17:03:20 EDT
Created attachment 1059669 [details]
File: proc_pid_status
Comment 12 Giulio 'juliuxpigface' 2015-08-05 17:03:22 EDT
Created attachment 1059670 [details]
File: var_log_messages
Comment 13 Giulio 'juliuxpigface' 2015-10-03 17:32:54 EDT
I'm closing this report since I can't reproduce the bug on Fedora 23 Final TC1, even if pnmixer's version is the same.

This probably was a problem of another component and has been solved by an update.

Note You need to log in before you can comment on or make changes to this bug.