Bug 125076 - Cups generates wrong printcap file from printers.conf
Summary: Cups generates wrong printcap file from printers.conf
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: cups   
(Show other bugs)
Version: 2
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-02 15:49 UTC by Honza
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 20:19:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Honza 2004-06-02 15:49:42 UTC
Description of problem:

CUPS incorrectly generates /etc/printcap (printcap) file from /etc/cups/printers.conf 
(printers.conf) file

Version-Release number of selected component (if applicable):

cups-1.1.20-6

How reproducible:

printers.conf file contains a printer defined this way :

<DefaultPrinter HP1>
(...)
DeviceURI lpd://arkas.../lj5c?reserve=yes
(...)
</Printer>

I mean, that on the arkas server lj5c printer should be used. BUT after restarting cupsd, 
which generates the printcap file, this is the result in the printcap file :

HP1|HP1:rm=nil...:rp=HP1:

where nil... = localhost. Both the server and printer are incorrect. It simply can't print 
and consequently lpq command generates "Error: loop in printcap".

When I repaired the printcap file, everything worked OK. Unfortunately I can't work 
without cups, because some applications (OpenOffice) reads the list of printers from 
the cupsd daemon.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Bad /etc/printcap

Expected results:

Correct /etc/printcap

Additional info:

Comment 1 Tim Waugh 2004-06-02 16:32:51 UTC
What does '/usr/sbin/alternatives --display print' say?

Comment 2 John Thacker 2006-04-24 20:19:34 UTC
Closing due to lack of response by reporter.


Note You need to log in before you can comment on or make changes to this bug.