Bug 1250760 - Content View Filter by Date filter seems to be off a day
Content View Filter by Date filter seems to be off a day
Status: CLOSED DUPLICATE of bug 1215756
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views (Show other bugs)
6.0.8
Unspecified Unspecified
high Severity high (vote)
: GA
: --
Assigned To: Chris Peters
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 20:59 EDT by jnikolak
Modified: 2016-05-19 01:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-29 13:23:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
after_filters (68.50 KB, image/png)
2015-08-05 20:59 EDT, jnikolak
no flags Details
cv_filters (53.36 KB, image/png)
2015-08-05 21:00 EDT, jnikolak
no flags Details
foreman_debug (11.28 MB, application/x-xz)
2015-08-05 21:04 EDT, jnikolak
no flags Details

  None (edit)
Description jnikolak 2015-08-05 20:59:40 EDT
Created attachment 1059683 [details]
after_filters

Description of problem:

Customer has Satellite with Rhev environment, they are using Satellite 6 to provision hyper-visors.

The Satellite successfully provisions the hypervisor, however when they try to install a specific package they get and error:

That package is:
# libvirt-lock-sanlock

How reproducible:

Steps to Reproduce:
1. Create Satellite 6.0.8
2. Create RhevM, Cluster
3. Setup Satellite with provisioning
4. Setup Satellite with repositories

5. Setup Satellite with the following channels
-> rhel-6-server-rhev-mgmt-agent-rpms
-> rhel-6-server-rpms

6. Create the Host Groups, Activation Keys, Environment, OS
7. Create the Content view, for the above repos
8. Create an errata filter to filter out:

Exclude all packages after 29/04/2015.
(screenshot attached)


9. In Rhev create the machine, that will end up being provisioned
10. Provision the server using Satellite, with deploy on parameter, adding the network details in step 9(above step)

11. Check to see if the repo's exist on the hypervisor that was built. 

The package doesnt exist, that the installation is asking for.

yum list libvirt*
Loaded plugins: package_upload, product-id, security, subscription-manager
Installed Packages

libvirt.x86_64  0.10.2-46.el6_6.6             @rhel-6-server-rpms
libvirt-client.x86_64  0.10.2-46.el6_6.6      @rhel-6-server-rpms
libvirt-lock-sanlock.x86_64 0.10.2-46.el6_6.6 @rhel-6-server-rhev-mgmt-agent-rpms


12. yum install 

Failed to install Host DEV-nsdadbe101t. Failed to execute stage 'Package installation': [u'libvirt-lock-sanlock-0.10.2-46.el6_6.4.x86_64 requires libvirt = 0.10.2-46.el6_6.4'].
	
Failed to install Host DEV-nsdadbe101t. Yum [u'libvirt-lock-sanlock-0.10.2-46.el6_6.4.x86_64 requires libvirt = 0.10.2-46.el6_6.4'].
 


Why is the package being excluded when the package date
# 4/11/15 6:23:55 AM EST

The filter we excluded is only after the 29th.
"Exclude all packages after 29/04/2015."

See: https://rhn.redhat.com/rhn/software/packages/details/Overview.do?pid=1061668

When not excluding by date, the package is seen by the client.


Is the following bugzilla related to this? 
Do we have any workarounds?

Content view filter errata by date not working:
--> https://bugzilla.redhat.com/show_bug.cgi?id=1199100
Comment 1 jnikolak 2015-08-05 21:00:10 EDT
Created attachment 1059684 [details]
cv_filters
Comment 2 jnikolak 2015-08-05 21:04:19 EDT
Created attachment 1059686 [details]
foreman_debug
Comment 3 Justin Sherrill 2015-08-06 20:09:08 EDT
tldr; 

publishing a content view with an errata exclude list of all errata after 4/29/2015 leaves you with a content view with errata from 4/29 and earlier.  Something is going wrong and we are off by 1 day.
Comment 6 Walden Raines 2015-12-03 10:50:30 EST
Is it possible that this is a duplicate of bug #1215756?  I changed the issued and updated columns to dates instead of timestamps which could fix this issue.
Comment 8 Chris Peters 2016-03-29 13:23:34 EDT

*** This bug has been marked as a duplicate of bug 1215756 ***

Note You need to log in before you can comment on or make changes to this bug.