Bug 125077 - system-config-network can't handle unexpected kernel version strings
system-config-network can't handle unexpected kernel version strings
Status: CLOSED DUPLICATE of bug 122223
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-02 11:53 EDT by Bryan O'Sullivan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan O'Sullivan 2004-06-02 11:53:57 EDT
In FC2, the system-config-network back end modules crash if the kernel
version string is in an unexpected format.

I'm running system-config-network-1.3.16-1.

My kernel version string is 2.6.3-1.1664-up.

When I run, I get a backtrace like this:

Component: system-config-network
Version: 1.3.16
Summary: TBf3ca2c97 NC_functions.py:54:kernel_version:ValueError:
unpack list of wrong size
Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 183, in ?
    from netconfpkg import NC_functions
  File
"/usr/src/build/377922-noarch/install/usr/share/system-config-network/netconfpkg/__init__.py",
line 61, in ?
  File "<string>", line 1, in ?
  File
"/usr/src/build/377922-noarch/install/usr/share/system-config-network/netconfpkg/Control.py",
line 28, in ?
  File
"/usr/src/build/377922-noarch/install/usr/share/system-config-network/netconfpkg/NC_functions.py",
line 78, in ?
  File
"/usr/src/build/377922-noarch/install/usr/share/system-config-network/netconfpkg/NC_functions.py",
line 54, in kernel_version
ValueError: unpack list of wrong size

Local variables in innermost frame:
release: 2.6.3-1.1664-up
machine: i686
version: #3 Mon Feb 23 14:46:20 PST 2004
nodename: camp4.serpentine.com
sysname: Linux
Comment 1 Harald Hoyer 2004-06-04 06:54:50 EDT

*** This bug has been marked as a duplicate of 122223 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:55 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.