Bug 125078 - Installer mis-detects Radeon IGP 340M graphics controller
Installer mis-detects Radeon IGP 340M graphics controller
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hwdata (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-02 12:02 EDT by Steve Snyder
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-12 08:52:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Snyder 2004-06-02 12:02:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040120

Description of problem:
On installation of FC2 my Xorg installation was configured to use the
svga driver.  That's the wrong selection for my "Radeon IGP 340M"
hardware.  I manually edited /etc/X11/xorg.conf, replacing "svga" with
the correct "radeon" driver and all is well.



Version-Release number of selected component (if applicable):
10.0-5

How reproducible:
Didn't try

Steps to Reproduce:
1. Install Fedora Code 2.
2. Note incorrect driver specified in config file.


Actual Results:  Two problem were observered as results of the
incorrect driver selection:
1. Distorted screen on transition from text to graphical modes.
2. Complaints of not enough MTRRs (the svga driver likes to have a lot
of distinct memory regions).


Expected Results:  Should see no problem entering or using the
graphical interface.


Additional info:

This is on a Compaq Presario 2570us notebook machine.

In RHL v9 the svga driver was correctly selected for this same chipset
because the radeon driver did not yet support the hardware.  A year
later radeon_drv.o does drive the 340M (and provides 2D acceleration).
 Perhaps the installer has not been updated to make the association
between the controller and the radeon driver?

# lspci
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon IGP 340M

I selected the anaconda component per the instructions on the Bugzilla
page.  Note, though, that I did a text install ("linux text" from
bootable FC2 CD #1).
Comment 1 Steve Snyder 2004-06-08 16:14:51 EDT
Oops!  Re-reading my bug report I see that I typed "svga" several
times rather than the correct "vesa".  When reading the above report,
note that it was the "vesa" driver that was selected for my hardware
by the FC2 installer.

This is a snippet from xorg.conf, as configured by the FC2 installer:

Section "Device"
        Identifier  "Videocard0"
        Driver      "vesa"
        VendorName  "Videocard vendor"
        BoardName   "VESA driver (generic)"
EndSection

Still, though, the wrong driver was selected for my I340 hardware.

Sorry for the confusion.
Comment 2 Mike A. Harris 2004-07-12 08:52:09 EDT
The hwdata package has been updated in rawhide with fixes for many
ATI chipsets.  Please update to the rawhide hwdata package and see
if it detects your chip properly now.  If the problem remains,
reopen the report and attach your X server log file or the output
of "lspci -n", so we can get the correct PCI device ID to make the
mapping.

Closing as "RAWHIDE".

Note You need to log in before you can comment on or make changes to this bug.