Bug 1250857 - dhcp6-change every 15 seconds
dhcp6-change every 15 seconds
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks: dualstack
  Show dependency treegraph
 
Reported: 2015-08-06 03:33 EDT by Ville Skyttä
Modified: 2015-11-10 12:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-10 11:24:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Syslog excerpt (5.14 KB, text/plain)
2015-08-06 03:33 EDT, Ville Skyttä
no flags Details
ip a output for the interface (496 bytes, text/plain)
2015-08-06 03:34 EDT, Ville Skyttä
no flags Details

  None (edit)
Description Ville Skyttä 2015-08-06 03:33:58 EDT
Created attachment 1059746 [details]
Syslog excerpt

My laptop dispatches a dhcp6-change action and dhclient renewal every 15 second in a IPv4+IPv6 enabled home Wifi network. Syslog excerpt and "ip a" output for the interface are attached.

I assume this is not normal. The Wifi/DHCP GW is a Cisco EPC3825 box, configured with DHCPv6 "valid lifetime" set to 60, but I don't know what the unit for that value is. Guessing minutes.

There is another F-22 box in the same network, it is IPv6 enabled as well, but with a wired network and no NetworkManager, and it does not show similar symptoms. I'm not sure if it actually gets anything from v6 DHCP though; its ifcfg-* file looks like it might, but there are for example no /etc/resolv.conf IPv6 entries on it and the "ip a" shows "mngtmpaddr" for its inet6 address, whatever that means.
Comment 1 Ville Skyttä 2015-08-06 03:34:27 EDT
Created attachment 1059747 [details]
ip a output for the interface
Comment 2 Fedora Admin XMLRPC Client 2015-08-18 11:00:30 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Ville Skyttä 2015-09-08 04:21:30 EDT
Ping, anything I can do to debug this?
Comment 4 Ville Skyttä 2015-11-10 03:42:24 EST
Ping #2, anything I can do to debug this further? Still happens in a fresh F23 install, same laptop.
Comment 5 Pavel Šimerda (pavlix) 2015-11-10 04:03:59 EST
Can you please provides details on the information returned by the Cisco? In my opinion `tcpdump -vvni wlan0` should be good enough (wlan0 being the active wireless interface).
Comment 6 Pavel Šimerda (pavlix) 2015-11-10 04:10:58 EST
(In reply to Ville Skyttä from comment #0)
> I assume this is not normal. The Wifi/DHCP GW is a Cisco EPC3825 box,
> configured with DHCPv6 "valid lifetime" set to 60, but I don't know what the
> unit for that value is. Guessing minutes.

Isn't it 60 seconds?
Comment 7 Ville Skyttä 2015-11-10 05:35:27 EST
I fiddled with the Cisco "valid lifetime" setting and somehow managed to bump it to 3600 and now I see "valid_lft 3600" and "preferred_lft 1800" infos from NM in syslog, and the frequent renewals stopped. I'm having trouble getting it changed back to anything else besides 3600 at least as far as stuff logged in syslog is concerned, but that might be because of the Cisco, its hard to grok when the box needs to be booted etc.

Anyway, so I suppose it's seconds indeed, and it beats me why they'd ship the product with a default of 60 seconds for IPv6 while the default for IPv4 is 9999 _minutes_. I'll try to ask the cable service provider.

So for now I guess there's nothing urgent to be done about this; I'll try to fiddle even more and get things to change to something else besides 3600 and will ping here if I fail and think it's due to something NM related.

It is quite puzzling that having valid_lft 60 and preferred_lft 30 results in renewals every 15 seconds, not 60 or 30.

Not sure if we should keep this open for the 15 vs 30/60 thing and/or waiting to see if I can get the lft to change to something else and see what happens then. Thoughts?
Comment 8 Pavel Šimerda (pavlix) 2015-11-10 07:33:08 EST
(In reply to Ville Skyttä from comment #7)
> Anyway, so I suppose it's seconds indeed, and it beats me why they'd ship
> the product with a default of 60 seconds for IPv6 while the default for IPv4
> is 9999 _minutes_

IPv4 and IPv6 are generally considered different. Not that I'm very happy with that. I've seen similar default lifetimes in other software as well.

> I'll try to ask the cable service provider.
> 
> So for now I guess there's nothing urgent to be done about this; I'll try to
> fiddle even more and get things to change to something else besides 3600 and
> will ping here if I fail and think it's due to something NM related.

It would be useful to know what exactly is the Cisco sending on the wire.

> It is quite puzzling that having valid_lft 60 and preferred_lft 30 results
> in renewals every 15 seconds, not 60 or 30.

It's not puzzling at all. If the preferred life time is 30 then it's too late to renew after 30 seconds. You have to renew *well before* the time is out.

> Not sure if we should keep this open for the 15 vs 30/60 thing and/or
> waiting to see if I can get the lft to change to something else and see what
> happens then. Thoughts?

In your bug report you are complaining about renewal every 15 seconds. My personal conclusion is that 15 seconds renewal is computed from the 30 seconds lifetime provided by the Cisco and that the system works well with respect to your local network configuration.
Comment 9 Dan Williams 2015-11-10 11:24:53 EST
Pavel's diagnosis is correct.  Also, DHCP times are always in seconds.

DHCP RFCs specify when the client should attempt to renew the address, and that begins a 1/2 of the lease time.  So the client would renew every 15 seconds per the RFCs.  If that's too fast, then you need to back off the lease time in the DHCP server unfortunately.

They probably used 60 seconds because that's a common time for the router advertisements, and they didn't understand the difference between RA and DHCPv6 :(
Comment 10 Ville Skyttä 2015-11-10 12:30:32 EST
(In reply to Dan Williams from comment #9)
> Pavel's diagnosis is correct.

Thanks to you both for taking the time to explain, it makes sense to me now.

> Also, DHCP times are always in seconds.

No they're not in this cable modem's web UI :)

Anyway, from syslog I gather NM and the Cisco box have a shared world view now, so NOTABUG is good.

Note You need to log in before you can comment on or make changes to this bug.