Bug 1250864 - ec returns EIO error in cases where a more specific error could be returned
ec returns EIO error in cases where a more specific error could be returned
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Xavi Hernandez
: Triaged
Depends On: 1245276
Blocks: glusterfs-3.7.4
  Show dependency treegraph
 
Reported: 2015-08-06 03:51 EDT by Xavi Hernandez
Modified: 2015-09-09 05:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1245276
Environment:
Last Closed: 2015-09-09 05:39:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavi Hernandez 2015-08-06 03:51:32 EDT
+++ This bug was initially created as a clone of Bug #1245276 +++

Description of problem:

ec xlator uses EIO error to report some failures that could be better identified by an ENOMEM or EINVAL for example. This needs to be fixed to allow better error handling on the application side.

Version-Release number of selected component (if applicable): mainline


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-07-22 16:07:36 CEST ---

REVIEW: http://review.gluster.org/11741 (cluster/ec: Minimize usage of EIO error) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

--- Additional comment from Anand Avati on 2015-07-27 15:58:59 CEST ---

REVIEW: http://review.gluster.org/11741 (cluster/ec: Minimize usage of EIO error) posted (#2) for review on master by Xavier Hernandez (xhernandez@datalab.es)
Comment 1 Anand Avati 2015-08-06 03:58:17 EDT
REVIEW: http://review.gluster.org/11852 (cluster/ec: Minimize usage of EIO error) posted (#1) for review on release-3.7 by Xavier Hernandez (xhernandez@datalab.es)
Comment 2 Anand Avati 2015-08-08 11:37:00 EDT
COMMIT: http://review.gluster.org/11852 committed in release-3.7 by Xavier Hernandez (xhernandez@datalab.es) 
------
commit 0e0c3ec84c73bc5fcda16ed743f9d3dc0a582c03
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Tue Jul 21 18:05:06 2015 +0200

    cluster/ec: Minimize usage of EIO error
    
    >Change-Id: I82e245615419c2006a2d1b5e94ff0908d2f5e891
    >BUG: 1245276
    >Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    >Reviewed-on: http://review.gluster.org/11741
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    
    Change-Id: Ifd3d63f88a686a2963c5ba2e62110249f84f338d
    BUG: 1250864
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/11852
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Kaushal 2015-09-09 05:39:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.