Bug 1250896 - results.xml.gz file with multiple runs should not have same file names
results.xml.gz file with multiple runs should not have same file names
Status: CLOSED NOTABUG
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 05:09 EDT by Anshul Behl
Modified: 2016-02-29 19:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-06 07:34:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anshul Behl 2015-08-06 05:09:15 EDT
Description of problem:

On extracting a cloud submitted file I got the below file names:
image_history.xml, firstboot.xml, image_history.xml, firstboot.xml, 
ping.err, ping.xml, ping.err, ping.xml, ssg-errors.log, ssg-results.xml, 
ssg-results.html, ssg-errors.log, ssg-results.xml, ssg-results.html, 
yum.xml, yum.xml, 
sosreport-test-instance-suprith2-20150615082232.tar.xz, 
sosreport-test-instance-suprith2-20150615082232.tar.xz.md5, 
sosreport-test-instance-suprith2-20150615083129.tar.xz.md5, 
sosreport-test-instance-suprith2-20150615083129.tar.xz


As you can see some names are repeated in the file because there were multiple runs in single file.
CWE has checks in place for same file names and so does CAAS, this results is errors in certification workflow.

Please changes the names by appending something like run number with the file name like 1-image_history.xml etc. to encounter this.


Version-Release number of selected component (if applicable):
redhat-certification-1.0-20150723.el7.noarch

How reproducible:
Everytime
Comment 1 Greg Nichols 2015-08-06 07:18:03 EDT
How are you extracting these files?
Comment 2 Anshul Behl 2015-08-06 07:29:31 EDT
Greg I am using a XMLParser that I have written for the same.
I am using them for my automation testing.
Comment 3 Greg Nichols 2015-08-06 07:34:30 EDT
This isn't a bug then.   The results.xml format has attachments organized by test run and test.   There is no requirement that attachment file names be unique.  If necessary, your XMLParser can rename the files on extraction.
Comment 4 Anshul Behl 2015-08-06 07:46:59 EDT
Greg,

Brief description of the issue:
- This has nothing to do with my scripts.
- There were two openstack certifications that failed recently due to this, what was happening was the rhcertlog file had two runs/ two openstack log files in it and CAAS was rejecting then saying 409 conflict error.
- CWE has the logic in place where it will stop the processing if CAAS returns something like that.
- Now if we do not make this change, partners can't submit files with multiple runs for cloud/openstack.

pmao and sgupta can describe the same issue better.
Comment 5 Greg Nichols 2015-08-06 10:00:11 EDT
This is bug in CaaS then, as it should handle a results file with more than one run.
Comment 6 MaoPeng 2016-02-29 19:03:05 EST
bug has been closed.

Note You need to log in before you can comment on or make changes to this bug.