Bug 1250907 - KRDB Image does not map - Ubuntu: ceph[1.3.0]
KRDB Image does not map - Ubuntu: ceph[1.3.0]
Status: CLOSED NOTABUG
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD (Show other bugs)
1.3.0
x86_64 Linux
unspecified Severity medium
: rc
: 1.3.2
Assigned To: Josh Durgin
ceph-qe-bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 05:32 EDT by rakesh
Modified: 2017-07-30 11:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-06 16:25:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rakesh 2015-08-06 05:32:08 EDT
Description of problem: 

when trying to map RBD image, the following error throws up : 

  cu@magna086:~$ sudo rbd map mypool/f1
  rbd: sysfs write failed
  rbd: map failed: (5) Input/output error 
 

  Ubuntu Kernel Version : 3.13.0-61-generic

  cu@magna086:~$ sudo rbd info mypool/f1
  rbd image 'f1':
  size 2048 MB in 512 objects
  order 22 (4096 kB objects)
  block_name_prefix: rb.0.8fe0.238e1f29
  format: 1


  cu@magna086:~$ sudo rbd --version
  ceph version 0.94.1.4 (944951aae2783417100ff0f1078a20bcdcdb605d)


Log link: http://pastebin.test.redhat.com/303292
Comment 2 Josh Durgin 2015-08-06 12:08:24 EDT
dmesg tells us why:

[75960.625411] libceph: mon0 10.8.128.33:6789 feature set mismatch, my 4a042a42 < server's 104a042a42, missing 1000000000

http://cephnotes.ksperis.com/blog/2014/01/21/feature-set-mismatch-error-on-ceph-kernel-client

1000000000 is the feature bit for CRUSH_V2, i.e. newer indep or SET steps in your crushmap. You can either upgrade the kernel to 3.14 or later, which support these, or change your crush map to not use these features. I would suggest upgrading the kernel since newer ones have more bug fixes for rbd as well.
Comment 4 Federico Lucifredi 2015-08-06 16:25:36 EDT
Interesting. Indeed, the 3.14 kernel supports more support, but for the purpose of this test, the question is: how did this test run on RHEL7 that has a 3.10 kernel?

Josh: Perhaps the RHEL 7.1 kernel ships with a newer kRBD?

Harish: we should not be testing kRBD on Ubuntu anyway: we cannot fix those Ubuntu kernels, even if we find an issue, so kRBD support is only on RHEL. Looks like we forgot to drop that item when we made the test plan. Let's replace kRBD tests with some of your lower priority tests already in your lists.

Note You need to log in before you can comment on or make changes to this bug.