Bug 1250914 - ppc64le endianess check FAILED [NEEDINFO]
ppc64le endianess check FAILED
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lcms2 (Show other bugs)
7.2
ppc64le Linux
high Severity high
: rc
: ---
Assigned To: Richard Hughes
Desktop QE
: EasyFix, Patch
: 1272605 (view as bug list)
Depends On:
Blocks: 1295396 1297830 1313485 1243784 1246155 1289025 1297828 1317949 1334445
  Show dependency treegraph
 
Reported: 2015-08-06 05:47 EDT by Tomas Pelka
Modified: 2016-11-04 02:20 EDT (History)
8 users (show)

See Also:
Fixed In Version: lcms2-2.6-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:20:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dkaspar: needinfo? (snagar)


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2015-08-06 05:47:42 EDT
Description of problem:
Checking Base types ...Ok.
	Checking endianess ...FAIL!
	endianess:
		
	OOOPPSS! You have CMS_USE_BIG_ENDIAN toggle misconfigured!
	
	Please, edit lcms2.h and comment the CMS_USE_BIG_ENDIAN toggle.
	
	Checking quick floor ...FAIL!
	quick floor:
		
	OOOPPSS! _cmsQuickFloor() does not work as expected in your machine!
	
	Please, edit lcms2.h and uncomment the CMS_DONT_USE_FAST_FLOOR toggle.
	
	Checking quick floor word ...FAIL!
	quick floor word:
		
	OOOPPSS! _cmsQuickFloorWord() does not work as expected in your machine!
	
	Please, edit lcms2.h and uncomment the CMS_DONT_USE_FAST_FLOOR toggle.
	
	Checking Fixed point 15.16 representation ...Ok.
	Checking Fixed point 8.8 representation ...Ok.
	Checking D50 roundtrip ...Ok.
	Checking Creation of test profiles ................Ok.
	Checking 1D interpolation in 2pt tables ...Ok.
	Checking 1D interpolation in 3pt tables ...Ok.
	Checking 1D interpolation in 4pt tables ...Ok.
	Checking 1D interpolation in 6pt tables ...Ok.
	Checking 1D interpolation in 18pt tables ...Ok.
	Checking 1D interpolation in descending 2pt tables ...Ok.
	Checking 1D interpolation in descending 3pt tables ...Ok.
	Checking 1D interpolation in descending 6pt tables ...Ok.
	Checking 1D interpolation in descending 18pt tables ...Ok.
	Checking 3D interpolation Tetrahedral (float)  ...make[1]: *** [check] Segmentation fault
	make[1]: Leaving directory `/home/test/rpmbuild/BUILD/lcms2-2.6/testbed'
	make: *** [check-recursive] Error 1
	-------- make check has FAILED -------- 

Version-Release number of selected component (if applicable):
lcms2-2.6-2.el7

How reproducible:
100%

Steps to Reproduce:
1. make check
2.
3.

Actual results:
see summary, endianess check FAILED on ppc64le

Expected results:


Additional info:
only failing on ppc64le
Comment 2 Tomas Pelka 2015-09-07 05:40:46 EDT
Matthias is it feasible to fix for 7.2?

It is blocking bug 1246155 which on QA.
Comment 3 Tomas Pelka 2015-09-07 06:00:28 EDT
(In reply to Tomas Pelka from comment #2)
> Matthias is it feasible to fix for 7.2?
> 
> It is blocking bug 1246155 which on QA.

My bad it is not, so it can be postponed to 7.3.
Comment 4 Tomas Pelka 2015-10-23 08:55:57 EDT
*** Bug 1272605 has been marked as a duplicate of this bug. ***
Comment 6 Andrew John Hughes 2015-12-15 21:32:20 EST
Seems odd to me that this wouldn't be fixed for 7.2, given that LCMS 2 build is basically completely broken on ppc64le.

See bug 1272605 which has a fix for this, which also includes enabling the test suite so that issues like this are caught straight away.
Comment 8 Dan Horák 2016-01-13 07:52:56 EST
Can we make a z-stream for this fix? It is causing an immediate segfault in ghostscript on ppc64le.
Comment 9 Andrew John Hughes 2016-01-13 20:08:16 EST
Yes, as I said in comment 6, I don't see how the version shipped in 7.2 would be in any way usable. It's built as big-endian.
Comment 20 errata-xmlrpc 2016-11-04 02:20:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2426.html

Note You need to log in before you can comment on or make changes to this bug.