Bug 125092 - Anaconda does not test/report unsupported processor
Summary: Anaconda does not test/report unsupported processor
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-02 17:22 UTC by Joe Dupre
Modified: 2014-03-17 02:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 21:57:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Dupre 2004-06-02 17:22:31 UTC
Description of problem:

I was having what I though might be a GRUB problem (may still be), 
and then I read the release notes that says you must have a processor 
that supports EM64T.  Is this true?

If it is, then Anaconda should test for and report if you are trying 
to intall it on an unsupported processor.

Why is Fedora limited to such a miniscule subset of highest end 
processors???

From Intel:
Q3: Which Intel processors support Intel® EM64T and when will they be 
available?
A3: On February 17th, 2004, Intel announced the company will add 
Intel® EM64T to its IA-32 processors code named Nocona (future Intel® 
Xeon⢠processor for dual processing servers and workstations), 
Potomac (future Intel Xeon processor MP for multi-processing servers) 
and Prescott (future product for uni-processor servers and 
workstations). This was an initial technology disclosure. Intel will 
provide additional details as the introductions of these various 
products approach. 


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Install on pentium 3
2.
3.
  
Actual results:
Hangs at GRUB text screen.


Expected results:
Should boot!


Additional info:

This may in fact be a GRUB issue.  GRUB never makes it to the 
graphical screen  (it hangs after outputing "GRUB" in text mode), 
which is before the kernel is loaded.  But I don't want to waste time 
trying to get this to work on an unsupported processor.  Anaconda 
should test for and report that the existing processor is not 
supported.

Comment 1 Joe Dupre 2004-06-02 18:24:06 UTC
OK, re-checked download, and I definately got the i386 images.  Not 
the x86-64 images.  So the "release notes" for Fedora Core 2 listed 
on the website (http://fedora.redhat.com/docs/release-notes/)
incorrectly state that a EM65T equipped processor is required.  (OK, 
I know I should have checked the release notes on the discs first, 
but hey.)

I will re-address this issue with the GRUB group, now that I know my 
processor is supported...

Comment 2 Jeremy Katz 2004-06-03 03:32:09 UTC
Bill -- not sure why the x86_64 release notes are the ones posted.

Comment 3 Bill Nottingham 2004-06-03 16:52:45 UTC
Ed/Elliot - did we post the wrong relnotes?

Comment 4 Ed Bailey 2004-06-03 18:02:26 UTC
Bill -- sure looks like it; it only lists AMD64 and EM64T, so it is,
in fact, the x86_64 version...

Comment 5 Bill Nottingham 2005-03-02 21:57:37 UTC
This was fixed around the FC3 timeframe.


Note You need to log in before you can comment on or make changes to this bug.