Bug 1250926 - Wrong description of undercloud config file
Wrong description of undercloud config file
Status: CLOSED DUPLICATE of bug 1236707
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Director
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 06:17 EDT by Dariusz Smigiel
Modified: 2016-04-18 03:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-06 06:49:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dariusz Smigiel 2015-08-06 06:17:47 EDT
In undercloud.conf there is description about possible length of encryption key. When I've used "r00tme00" key, it throws an error:

"Error: 8 is not a correct size for auth_encryption_key parameter, it must be either 16, 24, 32 bytes long. at /etc/puppet/modules/heat/manifests/engine.pp:106 on node gklab-17-081.igk.intel.com
Error: 8 is not a correct size for auth_encryption_key parameter, it must be either 16, 24, 32 bytes long. at /etc/puppet/modules/heat/manifests/engine.pp:106 on node gklab-17-081.igk.intel.com
"

undercloud.conf
# Heat db encryption key(must be 8,16 or 32 characters. If left unset,
# one will be automatically generated. (string value)
undercloud_heat_encryption_key = r00tme00
Comment 3 Dariusz Smigiel 2015-08-06 06:49:10 EDT
dupe

*** This bug has been marked as a duplicate of bug 1236707 ***

Note You need to log in before you can comment on or make changes to this bug.