Bug 1250928 - Man page for ipa-server-install is out of sync
Man page for ipa-server-install is out of sync
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Pavel Picka
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 06:20 EDT by Abhijeet Kasurde
Modified: 2015-11-19 07:05 EST (History)
7 users (show)

See Also:
Fixed In Version: ipa-4.2.0-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:05:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Verify log for bz (671 bytes, text/plain)
2015-10-01 07:03 EDT, Pavel Picka
no flags Details

  None (edit)
Description Abhijeet Kasurde 2015-08-06 06:20:39 EDT
Description of problem:
There is no option called as '-N' in ipa-server-install, but man page describes this option in documentation

Version-Release number of selected component (if applicable):
ipa-server-4.2.0-3.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install ipa-server and dependent packages
2. Run 
ipa-server-install -r EXAMPLE.COM -n example.com -p root1234 -a root12345 --hostname ipaserver.example.com -N 


Actual results:
ipa-server-install: error: no such option: -N

Expected results:
Remove '-N' option from man page of ipa-server-install package and respective documentations

Additional info:
Comment 2 Martin Kosek 2015-08-06 08:16:59 EDT
I think the problem here is rather in the code. FreeIPA before 4.2.0:

# ipa-server-install -h | grep -i NTP
    -N, --no-ntp        do not configure ntp

FreeIPA 4.2.0:

# ipa-server-install --help | grep -i NTP
    --no-ntp            do not configure ntp

The short option is missing. Ticket is due.
Comment 3 Martin Kosek 2015-08-06 08:17:49 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5184
Comment 7 Pavel Picka 2015-10-01 07:03 EDT
Created attachment 1079034 [details]
Verify log for bz

Verified 

ipa-server-4.2.0-12.el7.x86_64
Comment 8 errata-xmlrpc 2015-11-19 07:05:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2362.html

Note You need to log in before you can comment on or make changes to this bug.