Bug 1251041 - Operating System created for Satellite server does not have partition table or templates assigned
Operating System created for Satellite server does not have partition table o...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high (vote)
: 6.1.2
: --
Assigned To: Brad Buckingham
Tazim Kolhar
http://projects.theforeman.org/issues...
: Triaged
: 1210394 (view as bug list)
Depends On:
Blocks: rhci-common-installer
  Show dependency treegraph
 
Reported: 2015-08-06 08:58 EDT by Brad Buckingham
Modified: 2017-02-23 14:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-15 03:22:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 11322 None None None 2016-04-22 11:46 EDT

  None (edit)
Description Brad Buckingham 2015-08-06 08:58:31 EDT
Description of problem:

It appears that when the Satellite server checks in via Puppet, an Operating System is created.  That operating system does not have any partition table or templates assigned to it; therefore, that operating system cannot be used 'as is' for provisioning hosts.  This causes issues for users (such as RHCI) which assume that the OS is correctly configured for use.

Version-Release number of selected component (if applicable):

Satellite 6.1.1 SNAP15 builds:

foreman-proxy-1.7.2.5-1.el7sat.noarch
foreman-1.7.2.33-1.el7sat.noarch

How reproducible:

always

Steps to Reproduce:
1. install Satellite on a RHEL 7.1 server
2. go to Hosts -> Operating systems
3. select the Redhat 7.1 OS

Actual results:
Observe that no Partition table or Templates are assigned

Expected results:
Partition table and Templates should be assigned

Additional info:

Katello has an 'after_create' filter on the redhat model (in models/katello/concerns/redhat_extentions.rb) that should get triggered to do these associations; however, that does not appear to be getting triggered by the current process for the Satellite server.  It does, however, get invoked when the server creates an OS as part of syncing a kickstart repository.
Comment 2 Brad Buckingham 2015-08-10 14:32:35 EDT
Created redmine issue http://projects.theforeman.org/issues/11322 from this bug
Comment 3 Bryan Kearney 2015-08-14 13:53:17 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/11322 has been closed
-------------
Brad Buckingham
Applied in changeset commit:katello|5befbde7e1ee7fface3ad83c2904a711bd6c38ba.
Comment 6 Tazim Kolhar 2015-08-31 03:04:37 EDT
VERIFIED:
# rpm -qa | grep foreman
ruby193-rubygem-foreman_discovery-2.0.0.19-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.20-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
foreman-proxy-1.7.2.5-1.el7sat.noarch
foreman-libvirt-1.7.2.35-1.el7sat.noarch
foreman-compute-1.7.2.35-1.el7sat.noarch
foreman-gce-1.7.2.35-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.2.3-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el7sat.noarch
dell-per805-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-debug-1.7.2.35-1.el7sat.noarch
foreman-ovirt-1.7.2.35-1.el7sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.14-1.el7sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
foreman-selinux-1.7.2.13-1.el7sat.noarch
foreman-postgresql-1.7.2.35-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el7sat.noarch
foreman-vmware-1.7.2.35-1.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
foreman-1.7.2.35-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.15.5-1.el7sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.9-1.el7sat.noarch
dell-per805-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
dell-per805-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch

steps:
1. install Satellite on a RHEL 7.1 server
2. go to Hosts -> Operating systems
3. select the Redhat 7.1 OS
Partition table and Templates are assigned
Comment 7 Brad Buckingham 2015-09-02 15:36:36 EDT
*** Bug 1210394 has been marked as a duplicate of this bug. ***
Comment 9 errata-xmlrpc 2015-09-15 03:22:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1786

Note You need to log in before you can comment on or make changes to this bug.