Bug 1251060 - Provider fails to check for updates if obsoletes are present
Provider fails to check for updates if obsoletes are present
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: puppet (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gaël Chamoulaud
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 09:03 EDT by Lukas Bezdicka
Modified: 2017-02-27 07:19 EST (History)
14 users (show)

See Also:
Fixed In Version: 4.1.0-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-07 07:01:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[PATCH] (PUP-4497) Ignore obsoleted packages on update check (19.30 KB, patch)
2015-08-06 09:45 EDT, Gaël Chamoulaud
no flags Details | Diff

  None (edit)
Description Lukas Bezdicka 2015-08-06 09:03:48 EDT
Description of problem:
PUP-4497 - Obsoleted packages in yum check-update output aren't ignored which causes the yum provider to fail

How reproducible:
always

Steps to Reproduce:
1. downgrade some installed package
2. run pupept
3. fail

Actual results:


Expected results:


Additional info:
Please backport https://github.com/puppetlabs/puppet/commit/1a3bd9b8ce838b204075e3b684c5075fbb5e3b96
Comment 1 Gaël Chamoulaud 2015-08-06 09:45:35 EDT
Created attachment 1059957 [details]
[PATCH] (PUP-4497) Ignore obsoleted packages on update check
Comment 2 Fedora Update System 2015-08-07 08:30:54 EDT
puppet-4.1.0-4.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/puppet-4.1.0-4.fc22
Comment 3 Fedora Update System 2015-08-07 21:13:09 EDT
Package puppet-4.1.0-4.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing puppet-4.1.0-4.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13018/puppet-4.1.0-4.fc22
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2015-09-08 20:22:47 EDT
puppet-4.1.0-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.