Bug 1251080 - oscap command line tool segfaults
oscap command line tool segfaults
Status: CLOSED DUPLICATE of bug 1220944
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openscap (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Šimon Lukašík
Marek Haicman
Depends On:
  Show dependency treegraph
Reported: 2015-08-06 09:07 EDT by Nick Carboni
Modified: 2015-08-06 12:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-08-06 12:18:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Profile element used to generate segfault (5.26 KB, text/html)
2015-08-06 09:07 EDT, Nick Carboni
no flags Details

  None (edit)
Description Nick Carboni 2015-08-06 09:07:00 EDT
Description of problem:
When the selected xccdf profile contains <select .../> tags with the selected attribute set to false oscap segfaults.

Version-Release number of selected component (if applicable):
OpenSCAP command line tool (oscap) 1.1.1

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info:
Sample select element from xccdf xml file
<select idref="accounts_password_pam_difok" selected="false"/>
Comment 1 Nick Carboni 2015-08-06 09:07:32 EDT
Created attachment 1059939 [details]
Profile element used to generate segfault
Comment 3 Nick Carboni 2015-08-06 11:37:24 EDT
Steps to reproduce:
-Add attached profile to the /usr/share/xml/scap/ssg/content/ssg-rhel7-xccdf.xml file above the existing profile.
-run the oscap command `oscap xccdf eval --profile cfme --results ./error-res.xml /usr/share/xml/scap/ssg/content/ssg-rhel7-xccdf.xml`

This command results in a segfault.
Comment 4 Marek Haicman 2015-08-06 12:18:15 EDT
Marking as a duplicate.

Just a note, that new [RHEL7.2] version behaves nicely, with output being:

OpenSCAP Error: Invalid selector '-1' for xccdf:value/@id='var_password_pam_dcredit'. Using null value instead. [xccdf_policy.c:2171]
Invalid selector '-1' for xccdf:value/@id='var_password_pam_ocredit'. Using null value instead. [xccdf_policy.c:2171]
Invalid selector '-1' for xccdf:value/@id='var_password_pam_lcredit'. Using null value instead. [xccdf_policy.c:2171]
Invalid selector '-1' for xccdf:value/@id='var_password_pam_ucredit'. Using null value instead. [xccdf_policy.c:2171]

*** This bug has been marked as a duplicate of bug 1220944 ***

Note You need to log in before you can comment on or make changes to this bug.