Bug 1251095 - dnf doesn't discover undefined %epoch broken dep
dnf doesn't discover undefined %epoch broken dep
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: createrepo_c (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mlcoch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 09:09 EDT by Michael Schwendt
Modified: 2015-11-01 16:50 EST (History)
8 users (show)

See Also:
Fixed In Version: createrepo_c-0.9.1-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-01 16:50:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2015-08-06 09:09:38 EDT
dnf tells "Dependencies Resolved", but RPM's transaction check notices an undefined "%{epoch}" macro in a dependency. Yum is also affected.

For comparison:
bug 1251037 - Yum doesn't find undefined %epoch broken dep 


(!) Important: There is a fixed "blktap" build in updates-testing, so the problem is only reproducible as long as that fix is not pushed into "updates". In that case, it will be necessary to create a dummy broken package to include an undefined %epoch macro in a dependency again.


# rpm -q dnf
dnf-1.0.2-3.fc22.noarch

# dnf install blktap-devel -y
Last metadata expiration check performed 0:21:15 ago on Thu Aug  6 14:33:51 2015.
Dependencies resolved.
===============================================================================================================================================
 Package                           Arch                        Version                                       Repository                   Size
===============================================================================================================================================
Installing:
 blktap                            x86_64                      3.0.0-2.fc22.git0.9.2                         fedora                      243 k
 blktap-devel                      x86_64                      3.0.0-2.fc22.git0.9.2                         fedora                       21 k

Transaction Summary
===============================================================================================================================================
Install  2 Packages

Total download size: 263 k
Installed size: 773 k
Downloading Packages:
(1/2): blktap-devel-3.0.0-2.fc22.git0.9.2.x86_64.rpm                                                           233 kB/s |  21 kB     00:00    
(2/2): blktap-3.0.0-2.fc22.git0.9.2.x86_64.rpm                                                                 970 kB/s | 243 kB     00:00    
-----------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                          157 kB/s | 263 kB     00:01     
Running transaction check
Error: transaction check vs depsolve:
blktap(x86-64) = %{epoch}:3.0.0-2.fc22.git0.9.2 is needed by blktap-devel-3.0.0-2.fc22.git0.9.2.x86_64
To diagnose the problem, try running: 'rpm -Va --nofiles --nodigest'.
You probably have corrupted RPMDB, running 'rpm --rebuilddb' might fix the issue.
The downloaded packages were saved in cache till the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'
Comment 1 Michael Schwendt 2015-08-06 12:47:42 EDT
Followup to devel@ list. It's createrepo_c that only understand numbers as Epochs due to relying on strtol() as parser. Any non-number, such as an undefined macro or a typo, results in a default Epoch 0 in the repodata.
Comment 3 Fedora Update System 2015-10-20 09:09:20 EDT
createrepo_c-0.9.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-735f979d01
Comment 4 Fedora Update System 2015-10-26 14:31:31 EDT
createrepo_c-0.9.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update createrepo_c'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-735f979d01
Comment 5 Fedora Update System 2015-11-01 16:50:03 EST
createrepo_c-0.9.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.