Bug 1251121 - Unable to demote files in tiered volumes when cold tier is EC.
Unable to demote files in tiered volumes when cold tier is EC.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
: Reopened
Depends On:
Blocks: 1252907 1260923
  Show dependency treegraph
 
Reported: 2015-08-06 09:28 EDT by Dan Lambright
Modified: 2016-06-16 09:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1252907 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:29:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Lambright 2015-08-06 09:28:44 EDT
Unable to demote files in tiered volumes when cold tier is EC.
Comment 1 Anand Avati 2015-08-06 10:06:47 EDT
REVIEW: http://review.gluster.org/11855 (cluster/tier: fix demotion when cold tier is EC) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 2 Anand Avati 2015-08-11 15:35:48 EDT
REVIEW: http://review.gluster.org/11855 (cluster/tier: fix demotion when cold tier is EC) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 3 Anand Avati 2015-08-12 07:49:11 EDT
COMMIT: http://review.gluster.org/11855 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit e65160c5bec78e7385eedf3cf02d9cdcb756db0c
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Thu Aug 6 09:59:35 2015 -0400

    cluster/tier: fix demotion when cold tier is EC
    
    We did not set the gfid in the loc structure in tier demotion. EC
    has a sanity check which fails FOPs when the loc gfid mismatches
    with the file attribute. When the FOP failed demotion was aborted.
    
    Change-Id: I69022c9ccb135b86e1feea93b01801b6a4100509
    BUG: 1251121
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/11855
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 4 Nagaprasad Sathyanarayana 2015-10-25 11:16:49 EDT
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.
Comment 5 Niels de Vos 2016-06-16 09:29:42 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.