Bug 1251126 - [RFE] EL 7.2 emulated machine level
[RFE] EL 7.2 emulated machine level
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RFEs (Show other bugs)
---
Unspecified Unspecified
high Severity unspecified (vote)
: ovirt-3.6.0-ga
: 3.6.0
Assigned To: Martin Betak
Nikolai Sednev
virt
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 09:40 EDT by Michal Skrivanek
Modified: 2016-02-10 14:23 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1201508
: 1384516 (view as bug list)
Environment:
Last Closed: 2015-11-27 02:55:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michal.skrivanek: ovirt‑3.6.0?
ylavi: planning_ack?
michal.skrivanek: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47224 master MERGED core: Add EL 7.2 emulated machine level Never
oVirt gerrit 47248 ovirt-engine-3.6 MERGED core: Add EL 7.2 emulated machine level Never
oVirt gerrit 47257 ovirt-engine-3.6.0 MERGED core: Add EL 7.2 emulated machine level Never

  None (edit)
Description Michal Skrivanek 2015-08-06 09:40:16 EDT
We want to use 7.2 qemu-kvm and the emulated machine type for consistency
Needed for latest QEMU features available in qemu 2.3 (namely hotplug RAM)

pending on CentOS 7.2 availability
Comment 1 Michal Skrivanek 2015-08-06 09:41:09 EDT
RHEV specific changes should be reverted once this is addressed upstream
Comment 2 Michal Skrivanek 2015-09-29 07:14:29 EDT
Since CentOS 7.2 is still not released the proper 7.2 support needs to wait.
Still, we want to do it as soon as it is out as some features depend on it(namely ppc64le) and it has a couple of bug fixes in qemu/libvirt already
Comment 3 Michal Skrivanek 2015-10-08 10:21:12 EDT
Ok so, the new qemu and related packages are now delivered by the following ovirt repos:
ovirt-master-snapshot-static
ovirt-3.6-snapshot-static
ovirt-3.5-snapshot-static

and the following cbs repo:
virt7-kvm-common-candidate
Comment 4 Red Hat Bugzilla Rules Engine 2015-10-20 09:56:25 EDT
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 5 Red Hat Bugzilla Rules Engine 2015-10-20 09:56:25 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 6 Red Hat Bugzilla Rules Engine 2015-10-20 10:15:22 EDT
This bug is marked for z-stream, yet the milestone is for a major version, therefore the milestone has been reset.
Please set the correct milestone or drop the z stream flag.
Comment 7 Red Hat Bugzilla Rules Engine 2015-10-20 10:15:22 EDT
Fixed bug tickets must have target milestone set prior to fixing them. Please set the correct milestone and move the bugs back to the previous status after this is corrected.
Comment 8 Red Hat Bugzilla Rules Engine 2015-10-20 10:15:22 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 9 Nikolai Sednev 2015-10-20 11:34:20 EDT
Please define verification steps to be performed in order to verify the bug.
Comment 10 Omer Frenkel 2015-10-21 06:50:16 EDT
on 3.6 cluster, RHEL hosts must support the 'pc-i440fx-rhel7.2.0' emulated machine type.
steps to reproduce:
1. add rhel host with older qemu package that doesnt support the above machine type.
2. host should move to non-operational.
3. update qemu package to support this type.
4. activate host.
5. host moves to up
Comment 11 Nikolai Sednev 2015-11-25 03:46:52 EST
Works for me on these components:
# rpm -qa vdsm libvirt-client sanlock qemu-kvm-rhev mom ovirt*
ovirt-vmconsole-host-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
ovirt-release36-002-2.noarch
ovirt-engine-sdk-python-3.6.0.4-0.2.20151123.gita2f81ed.el7.centos.noarch
sanlock-3.2.4-1.el7.x86_64
ovirt-setup-lib-1.0.1-0.0.master.20151119123055.gitfa908be.el7.centos.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.3.x86_64
ovirt-hosted-engine-ha-1.3.3-0.0.master.20151118145556.20151118145552.git71b535e.el7.noarch
ovirt-vmconsole-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
ovirt-release36-snapshot-002-2.noarch
libvirt-client-1.2.17-13.el7.x86_64
ovirt-hosted-engine-setup-1.3.1-0.0.master.20151118143825.gitc013638.el7.centos.noarch
ovirt-host-deploy-1.4.2-0.0.master.20151122153544.gitfc808fc.el7.noarch
vdsm-4.17.10.1-0.el7ev.noarch
mom-0.5.1-2.el7.noarch
Deployment was executed on two hosts and over NFS SD.
Comment 12 Sandro Bonazzola 2015-11-27 02:55:43 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.

Note You need to log in before you can comment on or make changes to this bug.