Bug 1251139 - Error message should be shown when OpenStack Cloud added as OpenStack Infra provider
Error message should be shown when OpenStack Cloud added as OpenStack Infra p...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
All All
high Severity high
: GA
: 5.4.2
Assigned To: Greg Blomquist
Pete Savage
: ZStream
Depends On: 1249692
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 10:25 EDT by Chris Pelland
Modified: 2015-09-09 09:10 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.4.2.0
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, the OpenStack Platform Director provider type was incorrectly labelled as OpenStack Infrastructure. Adding a non-director enabled OpenStack environment as a provider under this type, resulting in a user interface error. This bug was fixed by renaming the OpenStack infrastructure provider to "OpenStack Platform Director", to highlight the supported version of OpenStack Platform. Users are able to add the correct provider types in the new version of CloudForms Management Engine.
Story Points: ---
Clone Of: 1249692
Environment:
Last Closed: 2015-09-09 08:26:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Greg Blomquist 2015-08-10 15:59:04 EDT
https://github.com/ManageIQ/manageiq/pull/3784
Comment 2 CFME Bot 2015-08-10 18:05:59 EDT
New commit detected on manageiq/master:
https://github.com/ManageIQ/manageiq/commit/b7c8100366997a4addc9e848e62c507d1bdf7cc2

commit b7c8100366997a4addc9e848e62c507d1bdf7cc2
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Mon Aug 10 15:35:36 2015 -0400
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Mon Aug 10 17:16:23 2015 -0400

    Update name of OpenStack Infrastructure
    
    Change OpenStack infrastructure to "OpenStack Platform Director" in an attempt
    to call attention to the fact that a very specific type of OpenStack
    Infrastructure is supported.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1249692
    https://bugzilla.redhat.com/show_bug.cgi?id=1251139

 app/models/manageiq/providers/openstack/infra_manager.rb | 2 +-
 spec/models/ems_openstack_infra_spec.rb                  | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
Comment 4 CFME Bot 2015-08-18 18:08:28 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=918d880e607e30b16fae654165f3266ff154d11c

commit 918d880e607e30b16fae654165f3266ff154d11c
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Sun Aug 16 17:25:31 2015 -0400
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Tue Aug 18 13:29:55 2015 -0400

    Update name of OpenStack Infrastructure
    
    Change OpenStack infrastructure to "OpenStack Platform Director" in an attempt
    to call attention to the fact that a very specific type of OpenStack
    Infrastructure is supported.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1249692
    https://bugzilla.redhat.com/show_bug.cgi?id=1251139

 vmdb/app/models/ems_openstack_infra.rb       | 2 +-
 vmdb/spec/models/ems_openstack_infra_spec.rb | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
Comment 5 CFME Bot 2015-08-18 18:09:55 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=918d880e607e30b16fae654165f3266ff154d11c

commit 918d880e607e30b16fae654165f3266ff154d11c
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Sun Aug 16 17:25:31 2015 -0400
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Tue Aug 18 13:29:55 2015 -0400

    Update name of OpenStack Infrastructure
    
    Change OpenStack infrastructure to "OpenStack Platform Director" in an attempt
    to call attention to the fact that a very specific type of OpenStack
    Infrastructure is supported.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1249692
    https://bugzilla.redhat.com/show_bug.cgi?id=1251139

 vmdb/app/models/ems_openstack_infra.rb       | 2 +-
 vmdb/spec/models/ems_openstack_infra_spec.rb | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
Comment 6 CFME Bot 2015-08-18 18:11:19 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=918d880e607e30b16fae654165f3266ff154d11c

commit 918d880e607e30b16fae654165f3266ff154d11c
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Sun Aug 16 17:25:31 2015 -0400
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Tue Aug 18 13:29:55 2015 -0400

    Update name of OpenStack Infrastructure
    
    Change OpenStack infrastructure to "OpenStack Platform Director" in an attempt
    to call attention to the fact that a very specific type of OpenStack
    Infrastructure is supported.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1249692
    https://bugzilla.redhat.com/show_bug.cgi?id=1251139

 vmdb/app/models/ems_openstack_infra.rb       | 2 +-
 vmdb/spec/models/ems_openstack_infra_spec.rb | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
Comment 8 Pete Savage 2015-08-26 08:25:58 EDT
Naming is changed

Verified 5.4.2.0
Comment 10 errata-xmlrpc 2015-09-09 08:26:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1744.html

Note You need to log in before you can comment on or make changes to this bug.