Bug 1251149 - ipsilon gssapi path not found
ipsilon gssapi path not found
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipsilon (Show other bugs)
7.2
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 10:50 EDT by Scott Poore
Modified: 2015-11-19 05:50 EST (History)
1 user (show)

See Also:
Fixed In Version: ipsilon-1.0.0-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 05:50:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Poore 2015-08-06 10:50:48 EDT
Description of problem:

I'm trying to use gssapi to log into a test web server.  I kinit as user from terminal window then run firefox.  I get the user/password ipsilon login screen with a section on the right for "Other authentication methods:" which shows a link for "gssapi",  Clicking on this link I get the following error on screen:

"""
404 - Not Found

The path '/idp/login/gssapi/gssapi/negotiate' was not found.

If you think this is an error, contact the server administrator to resolve the problem.
"""

Rob noticed the double gssapi in the path which is the problem.

Version-Release number of selected component (if applicable):
[root@idp log]# rpm -qa|grep ipsilon
ipsilon-infosssd-1.0.0-5.el7.noarch
ipsilon-authform-1.0.0-5.el7.noarch
ipsilon-saml2-base-1.0.0-5.el7.noarch
ipsilon-filesystem-1.0.0-5.el7.noarch
ipsilon-saml2-1.0.0-5.el7.noarch
ipsilon-1.0.0-5.el7.noarch
ipsilon-tools-ipa-1.0.0-5.el7.noarch
ipsilon-base-1.0.0-5.el7.noarch
ipsilon-authgssapi-1.0.0-5.el7.noarch
[root@idp log]# rpm -qa|grep mod_auth_gssapi
mod_auth_gssapi-1.2.0-1.el7.x86_64


How reproducible:
unknown.

Steps to Reproduce:
1.  Setup IPA Master
2.  Install 2 IPA Clients
3.  On 1st client setup ipsilon IDP
4.  On 2nd client setup ipsilon SP
5.  On a workstation joined to IPA domain try to accesss SP with GSSAPI


Actual results:

Error mentioned above.

Expected results:

GSSAPI login works.

Additional info:
Comment 2 Rob Crittenden 2015-08-06 11:08:34 EDT
Upstream ticket:
https://fedorahosted.org/ipsilon/ticket/153
Comment 4 Scott Poore 2015-08-19 18:47:24 EDT
Verified.

Version ::

ipsilon-1.0.0-6.el7.noarch

Results ::

I was able to login to workstation as IPA user, kinit as user and run firefox and connect to SP.

First to configure browser, I had to connect to IPA WebUI first at https://master.testrelm.test.  This walked me through the firefox config.  

Then I returned to https://client1.testrelm.test and it loaded the SP page without password using GSSAPI.
Comment 5 errata-xmlrpc 2015-11-19 05:50:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2319.html

Note You need to log in before you can comment on or make changes to this bug.