Bug 1251173 - NullPointerException in ListItemLayoutManager
NullPointerException in ListItemLayoutManager
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fop (Show other bugs)
23
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Michael Simacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1206713
  Show dependency treegraph
 
Reported: 2015-08-06 11:46 EDT by John Eckersberg
Modified: 2015-08-14 22:08 EDT (History)
7 users (show)

See Also:
Fixed In Version: fop-2.0-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 22:08:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckersberg 2015-08-06 11:46:05 EDT
This is present in both F23 and rawhide, since both are on fop 2.0.  F22 and earlier is not affected.

Upstream bug:  https://issues.apache.org/jira/browse/FOP-2461

I can consistently reproduce the crash when building the docs for erlang.

I've scratch built fop for rawhide, including the upstream patch on trunk which fixes the NullPointerException (http://svn.apache.org/viewvc?view=revision&revision=1690396) and can verify that it fixes the issue when building the erlang documentation.

http://koji.fedoraproject.org/koji/taskinfo?taskID=10623582

Please include this patch for rawhide and F23.
Comment 1 Fedora Update System 2015-08-07 08:38:30 EDT
fop-2.0-2.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/fop-2.0-2.fc23
Comment 2 Fedora Update System 2015-08-08 12:20:47 EDT
Package fop-2.0-2.fc23:
* should fix your issue,
* was pushed to the Fedora 23 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fop-2.0-2.fc23'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13046/fop-2.0-2.fc23
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2015-08-14 22:08:01 EDT
fop-2.0-2.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.