Bug 1251181 - [aarch64] unhandled syscall: setuid (146) and setresgid (149)
[aarch64] unhandled syscall: setuid (146) and setresgid (149)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: valgrind (Show other bugs)
7.1
aarch64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Mark Wielaard
Miloš Prchlík
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 11:58 EDT by Patrik Kis
Modified: 2015-11-19 04:05 EST (History)
5 users (show)

See Also:
Fixed In Version: valgrind-3.10.0-13.el7
Doc Type: Bug Fix
Doc Text:
Cause: Valgrind didn't recognize the setuid and setresgid system calls on aarch64. Consequence: Programs using those system calls on aarch64 would generate a warning when running under valgrind. Fix: valgrind now recognizes those system calls. Result: No more warnings when running programs under valgrind that use those system calls.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 04:05:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 351140 None None None Never

  None (edit)
Description Patrik Kis 2015-08-06 11:58:25 EDT
Description of problem:
Valgrind drops the following error:

==10476== Memcheck, a memory error detector
==10476== Copyright (C) 2002-2013, and GNU GPL'd, by Julian Seward et al.
==10476== Using Valgrind-3.10.0 and LibVEX; rerun with -h for copyright info
==10476== Command: /usr/sbin/slapd -u ldap -g ldap -h ldap://127.0.0.1 -d0
==10476== 
--10476-- WARNING: unhandled syscall: 149
--10476-- You may be able to write your own handler.
--10476-- Read the file README_MISSING_SYSCALL_OR_IOCTL.
--10476-- Nevertheless we consider this a bug.  Please report
--10476-- it at http://valgrind.org/support/bug_reports.html.
==10476== 
==10476== HEAP SUMMARY:
==10476==     in use at exit: 81,118 bytes in 75 blocks
==10476==   total heap usage: 213 allocs, 138 frees, 118,947 bytes allocated
==10476== 
==10476== For a detailed leak analysis, rerun with: --leak-check=full
==10476== 
==10476== For counts of detected and suppressed errors, rerun with: -v
==10476== ERROR SUMMARY: 0 errors from 0 contexts (suppressed: 0 from 0)


Version-Release number of selected component (if applicable):
valgrind-3.10.0-11.el7.aarch64
openldap-2.4.40-5.el7.aarch64

How reproducible:
always

Steps to Reproduce:
# valgrind --leak-check=no --show-possibly-lost=no --malloc-fill=0xFF /usr/sbin/slapd -u ldap -g ldap -h ldap://127.0.0.1
==10660== Memcheck, a memory error detector
==10660== Copyright (C) 2002-2013, and GNU GPL'd, by Julian Seward et al.
==10660== Using Valgrind-3.10.0 and LibVEX; rerun with -h for copyright info
==10660== Command: /usr/sbin/slapd -u ldap -g ldap -h ldap://127.0.0.1
==10660== 
--10660-- WARNING: unhandled syscall: 149
--10660-- You may be able to write your own handler.
--10660-- Read the file README_MISSING_SYSCALL_OR_IOCTL.
--10660-- Nevertheless we consider this a bug.  Please report
--10660-- it at http://valgrind.org/support/bug_reports.html.
==10660== 
==10660== HEAP SUMMARY:
==10660==     in use at exit: 81,098 bytes in 74 blocks
==10660==   total heap usage: 205 allocs, 131 frees, 118,772 bytes allocated
==10660== 
==10660== For a detailed leak analysis, rerun with: --leak-check=full
==10660== 
==10660== For counts of detected and suppressed errors, rerun with: -v
==10660== ERROR SUMMARY: 0 errors from 0 contexts (suppressed: 0 from 0)
Comment 1 Mark Wielaard 2015-08-07 07:43:10 EDT
This seems to be setresgid which indeed hasn't been implemented for arm64 in valgrind.
Comment 2 Mark Wielaard 2015-08-09 18:40:06 EDT
This is fixed upstream in valgrind svn r15517.
Comment 3 Mark Wielaard 2015-08-10 18:02:43 EDT
Upstream patch has been backported to the fedora package valgrind-3.10.1-17.fc24.
Comment 6 Miloš Prchlík 2015-09-23 07:55:24 EDT
Verified for build valgrind-3.10.0-16.el7.
Comment 8 errata-xmlrpc 2015-11-19 04:05:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2259.html

Note You need to log in before you can comment on or make changes to this bug.